Aaron Calloway's blog

Bits and pieces of Exchange & Office 365

Error with moving mailbox in Exchange 2010 SP2 RU3+

Error with moving mailbox in Exchange 2010 SP2 RU3+

  • Comments 8

I was working with a customer today who had recently migrated to Exchange 2010 SP2 RU5 from Exchange 2007 and they had an issue when they were trying to move mailboxes between Exchange 2010 databases. Although the move did complete, it "Completed with Warnings" showing the following error in the move request details:

Warning: Failed to clean up the source mailbox after the move.

Error details:
MapiExceptionUnexpectedMailboxState: Unable to delete mailbox. (hr=0x80004005,ec=2634)

 

When we looked around a little bit, we found that all the mailboxes that had completed with this particular error ended up having a disconnected mailbox showing up in the Exchange Management Console.

With a little bit of research, I found that this is a bug that applies to Exchange 2010 SP2 RU3, RU4, and RU5. You can prevent this issue from happening in the future by upgrading to Exchange 2010 SP3. However, you still need to get those disconnected mailboxes out of there. To do this, you want to use the following commands in Exchange Management Shell:

1.) Run the command to find the specific mailboxes that were impacted by this bug.

Get-MailboxStatistics -Database <MAILBOXDATABASE> | Where { $_.DisconnectReason -eq "SoftDeleted" } | fl LegacyDN, DisplayName, MailboxGUID,DisconnectReason

 2.) Run this command to remove those disconnected mailboxes cleanly.

Remove-StoreMailbox –Database <MAILBOXDATABASE> –Identity <MAILBOXGUID> –MailboxState Softdeleted

 

After running these steps, we were able to successfully cleanup those disconnected mailboxes.

Comments
  • Hello Aaron,

    We installed Exchange SP3, and we´re moving from Exch 2007 to Exch 2010 and we´re having this error..

    Any advice??

    Thanks!

  • How about your Exchange 2007 version? Is it updated to the most current version?

  • Hi,

    Exchange 2010 has SP3, while Exchange 2007 has SP2 RU10.

    Thanks!

  • Thanks for replying,

    Exchange 2010 has SP3 while Exchange 2007 has SP2 RU10.

    Thanks!

  • My mistake, in 2007 is SP3 RU10.

  • My mistake, in Exchange 2007 is SP3 RU10.

  • My mistake, in Exchange 2007 is SP3 RU10.

    Thanks

  • Is there a hotfix or patch available?

Page 1 of 1 (8 items)
Leave a Comment
  • Please add 2 and 5 and type the answer here:
  • Post