I've been seeing a lot of emails and posts about people wondering how they can get VSIP 2005 Beta 1 to work with the December 2004 CTP release of VS 2005. The answer is that you can't and shouldn't. When changes are made to interfaces, classes, assemblies, etc...in Visual Studio, corresponding changes are made in VSIP. You will always need a matching build of VS & VSIP to play nicely together. If you are a MSDN Universal subscriber, you can download a version of the VSIP SDK that will work with the December 2004 CTP release at the MSDN Download Center.

Happy Extending!