Windows SharePoint Services V3 Beta 2 is out and you can download it here. WSS v3 does not install a policy file that redirects old SharePoint assembly requests to the new assemblies. For this reason, if you try to use WSS v3 Beta 2 with BizTalk 2006 WSS adapter, you will run into errors. In order to workaround this problem and take WSS v3 Beta 2 for a test drive together with BizTalk 2006 WSS adapter, you will need to write your own policy file or just update the web.config file of the WSS adapter web service. Here's what you need to do:

  1. Open web.config from C:\Program Files\Microsoft BizTalk Server 2006\Business Activity Services\BTSharePointAdapterWS
  2. Paste the following section into the web.config file, configuration section and save the file
     <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="Microsoft.SharePoint"
                              publicKeyToken="71e9bce111e9429c" />
            <bindingRedirect oldVersion="11.0.0.0"
                             newVersion="12.0.0.0"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>

If you have other apps that were compiled against the old SharePoint assembly and you want to see if they will work with the new SharePoint assemblies, you can paste the snippet above in the configuration section of the machine.config file. That will make the changes global to entire machine.

During my tests, WSS adapter worked nicely with WSS v3 Beta 2. There were a few intermittent issues like [Microsoft.SharePoint.SPException] Unable to complete this operation.  Please contact your administrator. or [Microsoft.SharePoint.SPException] The URL '/sites/BASSite/DestinationLibraryFromOrch/tmp-db04abaf-4a12-4e11-93c9-4338c17cc78c.xml' is invalid.  It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web.

However, the operation was succesful on the second retry performed by the adapter and since this is a beta product some annoyances are expected. If you decide to try WSS v3 Beta 2 yourself and you find worse problems, I would like to hear about them from you.

[Content below added/changed on June 14]

BizTalk 2006 Configuration routine for Windows SharePoint Services BizTalk Adapter Web Service/SharePoint Adapter fails to configure on WSS v3 Beta 2 (SharePoint 2007 Beta 2). In order to workaround this you can install and configure WSS adapter on WSS v2 and then upgrade to WSS v3.

An alternative is to configure the adapter web service manually. I haven't tried this approach but it should work. In this case you need to create a virtual folder on the IIS site hosting SharePoint and name that virtual folder BTSharePointAdapterWS. The virtual folder should point to C:\Program Files\Microsoft BizTalk Server 2006\Business Activity Services\BTSharePointAdapterWS folder. This virtual folder must run in its own application pool and this app pool needs to be a copy of the SharePoint app pool (app pool used by _layouts virtual folder). You also need to update the web.config file like below

  <authorization>
   <allow roles="MACHINENAME\SharePoint Enabled Hosts" verbs="GET,HEAD,POST"/>
   <deny users="*"/>
  </authorization>

These are my own workarounds and they are NOT supported by Microsoft. AFAIK, Microsoft has NOT announced yet if BizTalk 2006 will support WSS v3.