Here I would like to bring your attention to the new security update for WSS3.0 and MOSS 2007 Microsoft Security Bulletin MS10-039 Vulnerabilities in Microsoft SharePoint Could Allow Elevation of Privilege (2028554).
For more details you may read here for MOSS and for WSS3.0  .

The February 2010 CU  should have the fix as well, but just in case you don’t have regular update for your farm then installing the security update would do job.

Please pay attention to this issue raised after installing the Security Fix in question on the SBS (Small Business Server).