Akshay's Weblog

Quest for Oasis

Unable to configure SharePoint Products and Technologies Configuration Wizard

Unable to configure SharePoint Products and Technologies Configuration Wizard

Rate This
  • Comments 21

I started with MOSS 2007 today and first thing I did was to install MOSS 2007 J. The installation was successful with a few initial hiccups, but while trying to run SharePoint Products and Technologies Configuration Wizard, I got the following error message.

---------------------------
SharePoint Products and Technologies Configuration Wizard
---------------------------
Failed to start the database service MSSQL$OfficeServers.  Repair this product by selecting it from the Add/Remove Programs menu.
---------------------------
OK  
---------------------------

However I didn’t want to reinstall the SQL Express. I researched a bit and saw that the Registry Key for server role (HKLM/Software/Microsoft/Shared Tools/Web Server Extensions/12.0/WSS/ServerRole) is set incorrectly.  It was set to SINGLESERVER.

I changed ServerRole’s value from SINGLESERVER to APPLICATION and after this I was able to configure the MOSS successfully and it’s running fine now J.

NOTE: Please make sure you make a backup of the registry before you make any changes. Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system.

Leave a Comment
  • Please add 6 and 5 and type the answer here:
  • Post
Thanks for sharing your comment! If your comment doesn't appear right away, please be patient as it may take a few minutes to publish or may require moderation.
  • Good stuff. it took me 5 hours to find that out

  • thank you very much,your way is very cool

  • Thanks - was stressing about not getting past that error!!

  • awesome man

    very good.

    keep it up.

    helped me a lot.

  • Thanks man. It worked for me. Great Job.

  • just awesome! you made my day! thank you so much! it worked like champ!

  • Man you saved my life!!! I was stuck for over a week with this problem, tanks

  • Thank you for the info...worked on this all weekend and your fix did the trick. Keep up the great postings.

  • Thanks for the info. It works great. But could you (or anyone) explain to me what's the implication of changing the server role from SINGLESERVER to APPLICATION? I'm running a stand-alone server.

    Thanks,

  • Great!!! I am on stand alone. This worked for me. But little curious to the info SINGLESERVER vs APPLICATION.

  • Yep!! Thanks a lot! I was getting crazy with this stupid install process!

  • Thanks!!

    i have this error in Sharepoint 2010 and this helps! thanks

  • very helpful!! thank you thank you!

  • Akshay, my friend......you kicked my day off with this little and beautiful solution. I owe you one.

  • This worked like a charm. Thank you OP!

Page 1 of 2 (21 items) 12