Missing The (Access) Point...

  • Comments 0

Let's face it, the only proper way to connect computers together is with real wire in the form of good quality Ethernet cables and switches. The current all-encompassing drive towards wireless was, I reckoned, just fad that would soon pass. At least, that's what I though a few years ago. The reality is, of course, very different now.

I hard-wired the whole of our house when we first moved in; it has cavity internal walls and plasterboard covered external walls so it was relatively easy to poke the wires into them and cut holes for Ethernet sockets. I even put speaker wires into each corner of the lounge so that I didn't have cables tucked under carpets or nailed to the skirting boards.

I suppose in the US what we call plasterboard would be called drywall. Though when a colleague based in Redmond happened to mention that he had water leaks in his bathroom and was having to remove all the boards, I couldn't help asking if it was now actually wetwall.

Anyway, a compact 16-port switch in the study connects everything together, and links into the proxy server in the server cabinet in the garage. Reliable high speed networking, and plug in anywhere - what more could you want? Though this was more than ten years ago, and the discovery that where we live there is almost no FM radio or DAB (digital audio broadcast) signal meant that Internet streaming radio was the only way to satisfy our insatiable demands for loud rock music.

And Internet radios rarely have an Ethernet socket, and end up being located in the kitchen - the one room of the house that doesn't have an Ethernet socket. So, some seven years ago I was forced into nailing a wireless hub to one of the protruding ends of my network. And there it's been ever since, blinking soulfully at me from a high shelf and generally minding its own business.

Of course, over the years, the number of devices it feeds has grown. As well as the high-fidelity Internet radio streams that pass through it for most of every day there are now two smartphones, a couple of tablet computers, a laptop or two, and a bird-box camera. The wireless hub uses the old steam-powered radio standards with a maximum of 54 Mbps and so it's no wonder that, some days, everything slows down.

So I decided that the time was right for a network upgrade. The 16-port switch in the study is only 10/100 so it was replaced with a new TP-Link Gigabyte model, and I ordered a new wireless hub that does dual 2.4 MHz and 5 MHz concurrently, with up to 450 Mbps on each. That should make everything fly!

However, nothing ever seems to be as easy as you expect. I blame the manufacturer's naming policy, though doubtless my own non-capabilities as a network administrator are partially culpable. You see, I reckoned that a wireless router was something with an ADSL or cable modem built it, so what I needed was a wireless access point. But all the ones I found seemed to be for use as repeaters with an existing wireless router. Then I found the NetGear kit that is a "wireless router" but without a modem in it. It seemed to be exactly what I needed.

And I expected that installing it would easy, just a matter of setting the same fixed IP address, the same hidden SSID, the same security mode and passcode, and the same list of MAC addresses as the old one. Until I looked at the installation instructions. For some strange reason the first six pages are full of dire warnings to power off your ADSL or cable modem, take the batteries out, turn round three times and count to ten, and plug the wireless router into it using "the yellow cable supplied in the box." I've had "yellow wire problems" before, and for the life of me I couldn't see what all this palaver has to do with tagging a wireless hub onto the end of my network.

Instead, I plugged it into my laptop. But which of the five ports on the router should I use? The nice bright yellow one seemed too tempting to resist, but that didn't work. Turns out that it's supposed to be LAN port 1. And, amazingly, up popped the configuration screen. Which, of course, refused to do anything at all because it couldn't detect an Internet connection. Only when I found the Advanced Setup pages could I actually do anything with it (and by that time I'd thrown the instructions away).

Not that the instructions or the built-in configuration help notes are actually much help when you need to figure out some of the settings. For example, do I use the same SSIDs for the 2.4 MHz and 5 MHz channels or different ones? I chose to use the same on the grounds that, most days, it would be nice to just connect to anything. I don't really care which. Or even if its my neighbour's. But a search of t'Internet reveals mixed opinions on this; it mainly seems to depend on whether you want to be able to tell them apart when you connect.

After three configuration attempts that ended with the "can't connect to router" message followed by the obligatory "go find a paper clip" (to press the reset button) activity, I finally figured out to completely ignore the tempting yellow socket and any configuration connected with "Internet". After that it all went swimmingly. It's a shame that it was only after all the fiddling about that I found this page on the NetGear site that explains how to do it all when you just want a wireless access point. OK, so it's for older models than the kit I have, but it still seemed to be relevant.

The important bit is where you suddenly figure out that you don't use (or need) the tempting yellow socket, and that you also spent twice as much money as you needed to because what you've bought is a "Wireless Router Without A Modem Even Though The Natural Meaning Of The Term Is One With A Modem In It" instead of a "Wireless Access Point That Is Not A Wireless Repeater And Can Be Used Standalone".

So by now I've got a wireless hub that should be able to connect to the Internet and do magic things, but can't because the tempting yellow socket is empty; will quite happily connect directly to a USB drive to stream music, and even make files accessible over the Internet, but can't because the tempting yellow socket is empty; can do firewalling and provide a guest network, but can't because the tempting yellow socket is empty; has three spare Ethernet ports to connect other stuff to, but they're empty because I already have a proper wired network; can do 450 Mbps on 2.4 GHz but that will kill all my neighbours' wireless connections; and can act as a wireless repeater, but I don't need that capability.

After a restless night dreaming about tempting yellow sockets, the next day I dug out the full PDF manual on the CD provided with the router, convinced that it must say something useful. A search for "access point" found the following help item:

Yep, that's all it says about it. And the option is not even on that page of the configuration interface. But there is another page called "Wireless AP" (I suppose if I'd been thinking logically I'd have realized that AP stands for Access Point). And here's what that page looks like when you select the uninformative "AP Mode" checkbox. Notice the contents of the help page - the big black rectangle at the bottom of the screen.

Aha! When you also check the next (uncaptioned) checkbox, which magically appears after you select AP Mode, you get text boxes to enter the long-anticipated IP address, subnet mask, gateway, and DNS servers. So I fill all that in, select Apply to reboot the router, and swap my network cable to the tempting yellow socket. And it works! Even the "Internet" page in the configuration now shows "Connected" and it sets the router's clock to the correct date and time. Maybe I've solved it?

Except now all those fancy features I paid so much extra for are disabled in the menus - but at least now I know I can't use them. However, where are the other options I expected to find in a top of the range wireless router? Such as the ability to tune the signal strength (I ran my old one at half power both to avoid annoying the neighbors and for security purposes). Or the ability to disable remote access to the configuration pages over the wireless link. Surely this is an obvious attack vector?

And, worst of all, I discovered that none of the wireless devices in our house can actually use the 5 MHz band...

Leave a Comment
  • Please add 8 and 7 and type the answer here:
  • Post

Missing The (Access) Point...