Downwardly Upgraded

  • Comments 0

So it looks like my upgrade from Windows 7 to Windows 8.1 actually downgraded me to Windows 6.3. I know I don't keep up with all the latest whizz-bang O/S releases, but I can't say I've ever heard anyone eulogising Windows 6.3 as the ideal choice for today's modern computing environment.

My regular reader will know that I'm generally averse to changing anything that's not completely broken, and I was quite happy with my old big-iron Dell Precision 7500. It's got bags of disk space, lots of CPUs, two big screens, and is easy to use. But, as usual, I got overtaken by technology.

The problem in this case was Visual Studio. I was still on 2010 but the latest Windows Azure stuff needs at least 2012 to work. So if I have to upgrade on a box that's been gradually filling up with the usual effluent from years of operation and upgrades, why not go the whole hog and upgrade everything? Windows 8.1, Visual Studio 2013, and Office 2013. Who says I'm afraid to take risks?

I even ran the upgrade checker to make sure the box was capable of handling all this exciting new software, and it generally looked optimistic. So I hop over to our software distribution site and grab Windows 8.1 Enterprise, thinking I might as well have all the available goodies. Except that, after an hour or so, I discover that you can't install Media Center on this. Well you can, if you read some blog posts on nefarious sites, but it seems to involve lots of hacks that I probably want to avoid.

So do I accept that I have to give up watching the golf or snooker on TV in a window on the second screen while I work, and no longer enjoy some old Kate Bush videos to smooth the path through my daily Windows Azure documentation woes? No chance. Just grab Windows 8.1 Pro from our software site and install that over the top. Amazingly, it worked, and I quite happily paid my £6.99 to buy the Media Center add-on.

And so, onwards I go installing the rest of my daily working environment requirements. It all seems to just work, and even Corel Photo and a couple of other apps that are supposed to have issues with Windows 8.1 installed and ran. But here's the intriguing thing. When I send emails through Outlook 2013 on this box it seems to have gained a new memory feature. The send/receive bar starts off OK with "Sending message 1 of 1". But when I send another message, even long after the first has gone and the Outbox is empty, it says "Sending message 2 of 2". Then "Sending message 3 of 3", and so on.

I guess it's neat because I can tell how many emails I sent since the last time I opened Outlook. Though, according to our IT help desk, this isn't supposed to happen. Or Outlook getting fed up every now and then and locking up with the message "Send/Receive" in the status bar and nothing coming in or out. The technical term for this is, I'm reliably informed, "broken".

And the fun doesn't end there. According to the computer list in my Windows Software Update Service, I'm now running Windows 6.3. Have I actually downgraded from Windows 7? Though WSUS does seem to deliver the Windows 8.1 patches and updates to the computer without complaining. And at least, when I look at the System Info page, it's comforting to see that Windows 8.1 thinks it is 8.1.

And it's also kind of nice to reminisce about the last time we had a "point" upgrade in Windows. Though I doubt many people will remember Windows 3.1 now. It's interesting that, in those days, the biggest problems you had were trying to get devices such as printers, disks, and network cards to work at all. Usually it involved fighting with lots of different drivers, cables, connectors, and configuration files.

Now everything hardware-wise just works, and the biggest problem is figuring out how to make the increasingly complicated software do what you want. Or even be able to tell what it is doing. My corporate laptop insisted I upgrade from Windows 8 to Window 8.1 this week (I'm not even the boss in my own office, never mind in my own house). It sat there with just a green box in one corner of the screen for a whole day with no sniff of a status bar or any indication it was actually doing anything. I had to go down to the garage and look at the lights on the router to see if there was any sign of life. Please can I have my animated network icon back in Windows 8.2?

Though I'm still a little nervous that, when I upgrade next time, it will just take me back to Windows 7 again. Or maybe I have to work my way through 6.4, 6.5, 6.6, etc. first...?

Leave a Comment
  • Please add 5 and 7 and type the answer here:
  • Post

Downwardly Upgraded