Just Collecting Dust...

  • Comments 0

It's Edinburgh Festival time again, and as usual they voted a winning joke. One of my favorite actors and stand-up comedians, Tim Vine, won it for the second time this year with a new one-liner: "I'm thinking of selling my vacuum cleaner. It's just collecting dust."

Likewise, it seems I now have a large and redundant lump of technology just collecting dust. If you succumbed through total boredom to read last week's post, you'll know that I suffered dead server syndrome and placed an order for a replacement to keep my over-complex and under-utilized domain network alive. And it looks, for the time being at least, that it will be staying in the box while I figure out how to go forward. Why? Because, for some inexplicable reason, the deceased server has risen from the dead and is happily chuntering along as though nothing happened.

I was passing the server cabinet the other day and, for no particular reason, decided to see if the old joke about the physicist, chemist, and computer programmer touring Switzerland in a car (near the end of this page if you haven't heard it) was true. Turn on the UPS and hit the power button on the server, listen for whirring noise, a few blinks of the LEDs on the front, and the KVM light comes on - just like the other day when it did the same every time but switched off after a second or two. Except, this time, it kept going, booted into Windows, and sat there looking at me as if to say "So what did you expect?"

And it kept going, all that day and all the next day. Even though it was disconnected from the network because it's a domain controller that I removed from the domain so connecting it would have screwed my Active Directory. Despite half a day spent trying to get it to run last week, it seems to have forgotten it's supposed to be broken. And there is absolutely nothing in the Event Logs to indicate what went wrong, or in the BIOS. The last entries just show a graceful shut down from the last time is was running two weeks ago. Maybe I just dreamed it all...?

So I need to remove Active Directory before I can connect back to the network and the domain. Running dcpromo just reminds me that I have to uninstall Certificate Services first. Then it asks if this is the last domain controller in the domain, and do I want to delete the domain. I don't, but as it's not connected I assume it can't actually delete the domain so I say yes. Then it furkles about for ages and tells me that it can't find the other domain controllers. Not surprising really as there is a three inch air gap in the network as far as its concerned.

So I go into AD Sites and Services on the was dead but now isn't box and try to remove the other domain controllers from it, but it won't let me because it can't see them. No matter what combination of options and other bodges I try, it refuses to do anything useful. In the end I resort to asking Bing, and discover that you have to run dcpromo /forceremoval, say yes to everything, and watch as it joyfully scavenges all the DC-related parts from your server. Then you just need to uninstall the Active Directory, DNS, and DHCP roles in Server Manager. And, of course, remember the admin password you set so you can log in again afterwards.

Next I join the machine back to the domain as an ordinary domain member, and everything comes back just like it was before. A quick backup to save the new machine configuration and then copy the latest exported Hyper-V VMs to it, and I have a cold-swap backup server all ready to go again. One of the VMs is a domain controller, so I'm covered if the main server fails now. As long, of course, as the was dead but now isn't box actually starts up when I need it...

The interesting question now is what went wrong last week. I'm switching my suspicions to the UPS because the one it uses has been problematic in the past. In the days before I installed solar panels, and was forced to install a new mains fuse-box just for the server cabinet because the total combination of hi-tech gadgetry in our house now has enough earth leakage to trip the RCD, this UPS was suspect. It had an occasional habit of tripping the RCD, even when turned off but still connected.

In fact, I'm only still using it because it replaced one I managed to destroy during a recent spring-clean and dust removal exercise in the cabinet. I remembered to disconnect the mains input and the battery, but forgot to unplug the safety connector on the back and managed to create a shower of sparks when I accidently touched something inside with the metal ferule of a paint brush. When I plugged it back in there was the most amazing display of flashing arc-lights and a deep "whoomph" that would make the owner of a Ford Escort with a 500 watt sound system proud.

So I've replaced the suspect UPS with another one that I know is OK, and bought a new one for the main server. Which means that I've spent more on UPSs this year than on servers, even including the new one. Which is now pretending to be a vacuum cleaner by just collecting dust...

Leave a Comment
  • Please add 8 and 7 and type the answer here:
  • Post

Just Collecting Dust...