Does the following error message looks familiar to you?

(When you go to Site Actions –> Site Settings –> [Site Administration] –> Term store management)
The managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started. Please Contact your Administrator.

image

Further check in ULS log and you see the following: (Product=SharePoint Server, Category=Taxonomy)

Permission check failed for WFE web app user: permission check: '0000000000001000' term store: 'Managed Metadata Service 1 Application'.

However in Central Admin site, you were able to browse Term Store Management Tool (Application Management –> [Service Applications] –> Manage service applications –> Managed Metadata Service 1 Application) and the page renders nicely without the error message as below.

image

 

If that’s the case, then you pretty much just missing the permissions for web application’s app pool ID to access Managed Metadata service application. All you have to do is to add the account used by the web app’s application pool into the ‘connection permissions’ as below. Try not to mess around with SQL user security/DB mappings as suggested by other posts.

Solution
=======

1. Go to SharePoint Central Administration Site –> Application Management –> [Service Applications] –> Manage service applications

2. Highlight the Managed Metadata Service that your web application is associated with. (Do not click on the link, just click somewhere else on that row to highlight it)

3. Click on Permissions button in the ribbon area.

4. Add the application pool account used by your web application and give it at least ‘Read Access to Term Store

image

5. click OK

 

Now you should be able to use term stored provided by the associated Managed Metadata Service Application.

 

- Allen