Here is some information that will be useful for those who get a failure message during setup of the Device Emulator in the Beta 1 release of Visual Studio 2005.

NOTE:If you did run into this issue please make sure you log a bug on the product feedback center so that we can track how many people ran into this issue at some point.

The messages would look similar to

Microsoft Device Emulator version 1.0: [2] Error Code 1603 for this component means “Fatal Error during Installation”

Or Microsoft Device Emulator version 1.0: [2] Setup failed on component Microsoft Device Emulator version 1.0

Or The installer has encountered an unexpected error when installing this package. This may indicate a problem with this package. The error code is 29999.

Or Failed to Open VPC Network Driver When starting the Device Emulator .

Some back ground on this component.

You would have noticed this new component listed in the feature tree during setup. This feature currently installs the Virtual Machine Network services that are used by the Microsoft Device Emulator. If these services don’t get installed then the Visual Studio IDE is not able to correctly communicate with the emulators.  

Why a failed setup?

This list may not be exhaustive however there are two common scenarios when the driver fails to install.

a)      if there was an older version of the driver on that machine that it could not upgraded (example if you had eVC 4.0 SP2 on the machine)

b)      if the property page for the network connections was open during setup. 

Other scenarios include intermittent problems with network causing this service to fail when installing.

Troubleshooting these issues

  1. My first recommendation is to reboot the machine. This fixes a flag set during the removal of the previous version of the driver which causes the upgrade to the newer version to fail.

  2. Thecheck to see if you have these services installed.
    1. Go to Start and the Control Panel
    2. Open Network Connections
    3. Select the properties of Local Area Connection  by right clicking on it and selecting properties
    4. You will be able to see (or not see) this service listed for this connection.
  3. if these services are not installed,
    1. Start the IDE and create a new Smart Devices Project (say a Pocket PC Project)
    2. Press F5
    3. From the deploy dialog select (Legacy) Emulator

You will see a dialog indicating the installation the Emulator and the driver.

If no error happens during the installation, this installation dialog will go away and the driver gets installs

Verify once again as in step1 to check that the driver is correctly installed

The version we ship in Beta is 2.5.452.0

Once this driver is installed all scenario will work as expected.

Also a note to anyone who is trying to install this, you need to be an admin on the machine to install this driver, other wise the service will not install.

Hope this information was useful in fixing failed driver setup issues. I will keep this page updated  with other issues and workaround for driver setup.

Amit Chopra