SharePoint adventures

A blog about random SharePoint stuff

July, 2011

Posts
  • SharePoint adventures

    Description goes missing on editforms

    • 0 Comments
    I had some trouble today finding the reason why descriptions set on fields did not show up on the editform. Turned out that Office Toolbox was installed and even though it was not active, made all descriptions disappear. Retracting the OfficeToolbox wsp...
  • SharePoint adventures

    Beware of conflicting field static names

    • 1 Comments
    Recently I came across a problem where pushdown of changes on a contenttype did not work when doing a feature upgrade. The appropriate AddContentTypeField command was specified in the feature.xml template: <AddContentTypeField ContentTypeId="averylongidhere"...
  • SharePoint adventures

    The good solution for versioning SharePoint 2010 webparts

    • 0 Comments
    Everyone who has had the pleasure of working in a team with other developers and using TFS with auto-incrementing version numbers most probably have faced the issue with webparts breaking after an increment in version numbers. This effect is not at all...
  • SharePoint adventures

    DataFormWebPart XSL variables are emtpy

    • 0 Comments
    If you discover that a DataFormWebPart added programmatically is missing values in its built in XSL variables, like HttpVDir or PageUrl, verify that the ViewFlag attribute is set to something other than zero on your webpart. Took me some time to find...
Page 1 of 1 (4 items)