Every now and then, I take a break from federated infrastructure to post something that is likely only relevant to me.  I recently purchased a new sound card (Creative Soundblaster X-Fi Extreme Audio) for a machine that is still running Windows XP.  I allowed the hardware wizard to recognize the device and pull the drivers from the CD that came with the card.  Some way into the installation, I blue-screened.  From that point forward, I could not keep the system up, so I rebooted to safe mode, pull the driver, rebooted normally, canceled the wizard installation and ran the direct install off the CD.

After that, everything worked fine, save one little issue.  At every logon, I received two errors.  The first error was:
RUNDll32.exe Entry point not found
The procedure entry point_except_handler4_common could not be located in the dynamic link library msvcrt.dll

Followed by:
Error loading P17RunE.dll
The specified procedure could not be found.

I also got an immediate notification from Creative that my drivers required an update.  I allowed the update, but found it interesting that the background screen indicated it was a Vista driver update.  Unfortunately, it couldn't be canceled.  Upon finishing, I received no errors, no BSODs, but couldn't get past the DLL errors.  I tried re-installing the msvcrt.dll from the original media, no changes.  It wasn't until I came across some discussions on the Creative forums that I got my solution. 

To rid these annoying errors, and allegedly resolve the problem, I needed to remove all references in the RUN key (regedit) to P17RunE.dll.  I haven't had the time or desire to research it, but I suspect that P17RunE.dll has some specific calls in Vista that don't exist in XP, hence the exception being thrown.  Removing the registry keys has proven stable.

Hat tip to jimholly who deserves the credit.