I have worked on an Http Error 500 issue recently. The issue has been successfully solved but the root cause is still pending research.

 

Problem Description

A web host server is managed by 3rd party software which is a commercial web hosting automation program.

Assume to create a web site and an application pool running under a local user account, it returns Http Error 500.0 – Internal Sever Error, details below:

Http Error 500.0 – Internal Sever Error

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server.

Please review this log entry to discover what caused this error to occur.

Detailed Error Information

Module: AspNetInitCltHostFailureModuel

Requested URL: http://YourWebSite/Login.aspx

Notification: BeginRequest

Physical Path:C:\inetpub\vhost\YourWebSite\httpdocs\Login.aspx

Handler: Plesk_Handler_0-1858614448

Logon Method: Not yet determined

Error Code:0x80004005

Logon User: Not yet determined.

 

Troubleshooting

 Initially, we suspect it is IIS configuration issue but it cannot be reproduced with the same setting in the lab environment.

 

We narrow down the root cause to permission denied. In the process monitor, we can see lots of Access Denied entries, however even if we assign the Administrator privilege to the local user account, the issue still occurs. Since it is production machine, we cannot reboot the machine to see if it makes any difference.

 

Then, we create a new local user account and give the prompt permission. Assign to application pool identity, the web site works ok. All issue gone.

 

Solution

Deleted the old application pool and re-created by the 3rd party software with the same local user account. The web site works as expected.

 

It can conclude that the issue is caused by the insufficient permission to access the resource with the local user account. We have tried to give enough permission to the user but didn’t work (it may need reboot machine to take it effect). The issue cannot be reproduced in our lab environment. It may be helpful to check the 3rd party software log for more information. We will do more research if get same issue next time.

 

Regards,

Anik Shen