Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

Updated cleanup tool that fixes package load failures in VS 2005 beta 2

Updated cleanup tool that fixes package load failures in VS 2005 beta 2

  • Comments 15

I've posted an updated version of the VS 2005 and .NET Framework 2.0 cleanup tool that will fix Package Load Failure error dialogs that might occur after uninstalling VS 2005 beta 1 or any of the Community Tech Preview (CTP) versions and then installing VS 2005.

You can click on this link to download the latest version of the VS 2005 beta cleanup tool.

 

Post-cleanup steps

One of the steps performed by this version of the cleanup tool removes some of the native images generated for VS 2005 beta 2.  These native images are used to improve the startup time when you launch the VS IDE.  You can regenerate these native images by running the following from a cmd prompt:

  • %windir%\Microsoft.NET\Framework\v2.0.50215\ngen.exe update /queue

If you are using VS 2005 beta 2 for web development on a local IIS server, you may see that ASP.NET 2.0 extensions for IIS are missing.  In order to resolve this, run the following from a cmd prompt after running the cleanup tool:

  • %windir%\Microsoft.NET\Framework\v2.0.50215\aspnet_regiis.exe -i

If the cleanup tool doesn't work for you

The cleanup tool has been tested by several people inside of Microsoft who had been receiving errors when trying to use the VS 2005 beta 2 IDE.  However, I'm still not certain that it will correctly clean up 100% of machines that have previously had beta 1 or a CTP installed.  If you try to run the tool and still encounter errors while using VS 2005 beta 2, please try to gather the following data and post a comment on my blog or contact me directly and we will take a look:

  1. Run %programfiles%\Microsoft Visual Studio 8\Common7\IDE\devenv.exe /log
  2. Gather the file \Documents and Settings\<your_username>\Application Data\Microsoft\VisualStudio\8.0\ActivityLog.xml for us to look at

Why do these errors happen?

If you are interested, I described the root causes of why certain uninstall/reinstall scenarios will encounter these problems in this blog post.

 

  • Almost. Now I only get 1 package load failure instead of 2 or 3. You can download my activity log here: http://www.manuet.com/downloads/activitylog.zip

    Let me know (joshREMOVEME@REMOVEMEmanuet.com) if you have any ideas.
  • Hi Josh, this is the interesting error from your log file:

    <errorinfo>Could not load file or assembly 'Microsoft.VisualStudio.TeamSystem.ELead.VSIP.SDK, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.</errorinfo>

    Did you only have VS 2005 beta 1 installed or did you also have any of the subsequent CTP versions (and if so which ones)?

    Also can you see any copies of this file if you look in %windir%\assembly on your machine?
  • I found a couple of Microsoft employees who hit this problem and also talked with Josh via email and we found that if you uncheck the Team Foundation Client item in the Visual Studio setup tree you will see this package load failure. To workaround this you can relaunch setup and add the Team Foundation Client item to your machine. See http://blogs.msdn.com/astebner/archive/2005/04/22/410982.aspx for more information.
  • Visual Studio Team System
    Beta 2 is out and thousands of you have downloaded and installed it with varying...
  • VS 2005 beta cleanup tool
  • So I just upgraded to VS Beta 2.&amp;nbsp; I had some issues.&amp;nbsp; They were all my fault apparently.&amp;nbsp;...
  • A big "Thank You" for this tool: It fixed what seemed to be an intractable problem!
  • De cateva zile aveam probleme cu Whidbey. Nu mai pornea. Mai exact la pornire in momentul aparitiei cadrului...
  • De cateva zile aveam probleme cu Whidbey. Nu mai pornea. Mai exact la pornire in momentul aparitiei cadrului...
  • De cateva zile aveam probleme cu Whidbey. Nu mai pornea. Mai exact la pornire in momentul aparitiei cadrului...
  • The clean up tool did not work for me. How can I send you the log file? Not sure what to do now.
  • Hi Robert - I received an email from you so I will try to help you via email and then report back the results as an additional comment on this blog post once we figure out how to fix your computer.

  • I just installed the FINAL release of VS 2005 on my laptop which has had no beta vesions of VS 2005 installed on it (although the first install of the final product failed). After successful installation of VS and MSDN i get these package load problems. I had VS 2003 on the machine before but I uninstalled that before installing 2005.

    I tried running the cleanup tool, which should have done nothing since I dont have any beta installed on my machine, but it deleted all the files for VS 2005 final... which surprised me... so i went ahead and re-installed 2005 and I still get this error.

  • Thanks for the help! Your page helped me fix a .net problem I have been working on for along time.

    Again Thanks,
    Allan
  • PingBack from http://www.keyongtech.com/651574-help-cannot-create-class-in

Page 1 of 1 (15 items)
Leave a Comment
  • Please add 5 and 4 and type the answer here:
  • Post