Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

Unified .NET Framework Troubleshooting Guide

Unified .NET Framework Troubleshooting Guide

Rate This
  • Comments 92

Details about the .NET Framework 2.0 setup packaging

Error codes that can appear during .NET Framework setup

How to repair a broken version of the .NET Framework that ships with the OS

How to resolve some specific types of .NET Framework setup failure

.NET Framework service pack install issues

Where to find log files

Useful tools

Deployment Guides

Other references

 

  • Hi Dominik Lambrechts - This is the error that I see in your log file:

    Error 1935.Er is een fout opgetreden tijdens de installatie van het onderdeel System.ServiceModel.Web,version="3.5.0.0",publicKeyToken="31bf3856ad364e35",processorArchitecture="MSIL",fileVersion="3.5.594.1152",culture="neutral". Zie Help en ondersteuning voor meer informatie. HRESULT: 0x8002802F. onderdeelinterface: , functie: CreateAssemblyCache, naam van onderdeel: {8AAC775A-59B0-4591-A44C-4FCF2BA3184D}

    The error code 0x8002802F usually means that there is something wrong with the .NET Framework 2.0 on the computer.  I'd suggest trying to use the steps at blogs.msdn.com/.../how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx to repair the .NET Framework 2.0 files, and I'd also suggest checking that the .NET Framework 2.0 registry keys listed at blogs.msdn.com/.../3260076.aspx are set to the correct values on your computer.

  • Hello Aaron,

    I am getting the following error when attempting to open a launcher for a mmorg I am beta testing

    "to run this application you must first install one of the following versions of the .NET Framework:

    v4.0.30319

    Contact your application publisher for instructions about obtaining the appropriate version of the .Net framework."

    I have repaired, uninstalled and reinstalled Net 4. Turned off my anivirus and reinstalled as administrator. I have uninstalled 1.1 and 3.5sp and still get the same error

    I need to know what to try next..

  • Hi Stan Lee - That's strange.  Normally, uninstalling + re-installing the .NET Framework 4 should solve this type of error.  I'd suggest trying to use the steps listed at blogs.msdn.com/.../8108332.aspx to fully uninstall all versions of the .NET Framework from your computer, then re-install the .NET Framework 4 Full and see if that will help solve this error.

    Also, what version of Windows are you running?

  • Hi AAron,

    I have successfully installed, at various times, TurboTax 2006, 2007, 2008, 2009, and 2010 on

    my laptop (Dell, Vista at SP2).  I install appropriate Windows updates when notified.  

    Recently, I was notified of an "Important" Security Update for Microsoft .NET Framework 4 on

    Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows Server 2008 x86

    (KB2446708).  Each time I have "installed" the update my Update History shows that it was

    installed successfully, and each time I power on the computer I am reminded that I have

    Important Updates for my computer.  When I look at update history, I now have five instances

    listed as successful installs of the .NET Framework 4.  

    However, I can no longer execute any of my TurboTax .exe files.  Each time I try I immediately receive the following message:

    "TurboTax Engine has stopped working."  The problem details are:

    Problem signature:

     Problem Event Name: APPCRASH

     Application Name: ttax.exe

     Application Version: 2007.9.9.85

     Application Timestamp: 47cf90fd

     Fault Module Name: ntdll.dll

     Fault Module Version: 6.0.6002.18327

     Fault Module Timestamp: 4cb73436

     Exception Code: c0000005

     Exception Offset: 000299a4

     OS Version: 6.0.6002.2.2.0.768.3

     Locale ID: 1033

     Additional Information 1: e51a

     Additional Information 2: 4c0d4d78887f76d971d5d00f1f20a433

     Additional Information 3: e51a

     Additional Information 4: 4c0d4d78887f76d971d5d00f1f20a433

    When I close the program, the same error message appears again: "TurboTax Engine has stopped

    working."  This time the problem details are:

    Problem signature:

     Problem Event Name: BEX

     Application Name: ttax.exe

     Application Version: 2007.9.9.85

     Application Timestamp: 47cf90fd

     Fault Module Name: StackHash_dd8f

     Fault Module Version: 0.0.0.0

     Fault Module Timestamp: 00000000

     Exception Offset: 7ffdf000

     Exception Code: c0000005

     Exception Data: 00000008

     OS Version: 6.0.6002.2.2.0.768.3

     Locale ID: 1033

     Additional Information 1: dd8f

     Additional Information 2: c897048e0a97d00641941a6f10aa8056

     Additional Information 3: 9ae5

     Additional Information 4: d7a0f278ec86bbde39a6c03caedebf21

    The only change in my system is the repeated attempts to install Important" Security Update

    for Microsoft .NET Framework 4 on Windows XP, Windows Server 2003, Windows Vista, Windows 7,

    Windows Server 2008 x86 (KB2446708).

    As a consequence I searched for a solution to the problem and came across the

    netfx_setupverifier.

    I ran the netfx_setupverifier with the following results:

    .NET Framework 2.0 SP2, .NET Framework 3.0 SP2, .NET Framework 3.5 SP1, all verified successfully, but:

    .NET Framework 4 Client failed with the message: "Product verification failed, See log for details."

    As was suggested in another post, I uploaded the appropriate log files to:

    cid-d15518850471fc6b.office.live.com/.../.Documents

    ngen_service.old.log

    ngen_service.log

    ngen.log

    It seems that there is an chronic problem with the installation and execution of various software and either corruption or update abnormalities with .NET Framework releases.  Before I proceed further, I would like to correct whatever problems this new .NET Framework 4 update, and restore my ability to execute my various versions of TurboTax.  This is critical because all of the personal tax data created when I ran those programs is now unavailable to me.

    Please help and advise me on what I should do to recover from this issue.

  • Hi Stan Kremp - This is strange.  From what I know, TurboTax uses the .NET Framework 3.5 SP1, and the .NET Framework 4 should not interfere with the .NET Framework 3.5 SP1 at all.  I haven't been able to get the link to your log files to work, but what I'd suggest to start with is to use the tool and the steps listed at blogs.msdn.com/.../8108332.aspx to fully remove the versions of the .NET Framework that are installed on your computer, then re-install the .NET Framework 3.5 SP1 and the .NET Framework 4.  Hopefully doing this will restore your ability to use TurboTax, and also it will hopefully resolve the Windows Update issues you were seeing.

  • I downloaded .NET 2.0 SP2 off of the Microsoft Website, and while extracting it says that "File is corrupt" and the file being extracted is "SitSetup.dll". When I try to manually extract the files with programs like Winzip and WinRAR, many of the files fail to extract. Do I need to download the file again?

  • Hi RMT2 - This type of error usually means that something went wrong while trying to download the setup program and the copy that you downloaded ended up corrupted.  I'd suggest deleting the copy you previously downloaded and trying again to download this setup program.

  • Thanks Aaron! Re-downloaded and now up and running :).

  • I will soon be uninstalling the only program on my computer that needs NET 4 Framework.  I would then like to uninstall NET 4 itself.  I am running Win 7/64 bit.

    Your Blog explains many things about removing NET 4, but several issues are not clear to me.

    1. There have been multiple Updates/Security Updates to both NET 4 Client Profile and NET 4 Extended,  I think eleven (11) in total.  

    a. Can I use Programs and Features to remove these various Updates/Security Updates?

    b. If so, should the Updates/Security Updates be removed before or after removing NET 4 Framework itself?

    2. It appears that NET 4 Client Profile and NET 4 Extended can be remove either with Programs and Features OR with your command line tools.  Should one method be preferred over another?

    Many Thanks for your guidance.

  • Hi BoxCoxGuy - For the .NET Framework 4, uninstalling the base product should also remove the updates.  I don't believe you need to install the updates separately.  I'd suggest using the Programs and Features control panel to remove the .NET Framework 4, and only use the tools on my blog as a last resort in case the normal uninstall process fails.

  • Thanks!  Just what I needed to know.

  • I cant update win  7 files  get code 80070643  please help resolve

  • Hi Ramon - That error code is a generic code that means "setup failed" but doesn't give any information about why it failed.  What exact product are you trying to install when you get this error?

  • OS Version Information: ...

    [7/31/2012, 15:26:16]OS Version = 6.1.7600, Platform 2

    [7/31/2012, 15:26:16]OS Description = Windows 7 - x86 Ultimate Edition

    problem:

    Exe (N:\4b5b8133d72544c94bd8faac\Windows6.1-KB958488-v6001-x86.msu) failed with 0x1a91 - Transaction support within the specified resource manager is not started or was shut down due to an error. .

    [7/31/2012, 15:32:38]PerformOperation on exe returned exit code 6801 (translates to HRESULT = 0x1a91)

    [7/31/2012, 15:32:38] Action complete

    [7/31/2012, 15:32:38]Error 0x1a91 is mapped to Custom Error:

    [7/31/2012, 15:32:38]OnFailureBehavior for this item is to Rollback.

    help me?

  • Hi Aaron Stebner,

    Yesterday I installed .net framework 3.5 sp1 in my computer after i look at my computer that i have no net framework installed . in the end it fails . when i look at my control panel , add/remove programs i have net framework 2.0 installed . i dont know why . i read some articles on how to fix net frame work 3.5 sp1 . none of them works . i have this problem

    [08/02/12,21:58:38] XPSEPSC Installer: [2] Component XPSEPSC Installer returned an unexpected value.

    [08/02/12,21:58:39] WapUI: [2] DepCheck indicates XPSEPSC Installer is not installed.

    [08/02/12,22:01:43] XPSEPSC Installer: [2] Component XPSEPSC Installer returned an unexpected value.

    [08/02/12,22:01:44] WapUI: [2] DepCheck indicates XPSEPSC Installer is not installed.

    i already have XPSEPSC INSTALLER and i install it . and it didnt work . i download log collection tools . please help me on this one .

    I just dont want to uninstall net framework 2.0 yet without me letting you know my real problem .

    where can i post my vslogs.cab ?

Page 5 of 7 (92 items) «34567
Leave a Comment
  • Please add 7 and 8 and type the answer here:
  • Post