Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

Update Rollup 2 for Windows XP Media Center Edition 2005 troubleshooting guide

Update Rollup 2 for Windows XP Media Center Edition 2005 troubleshooting guide

Rate This

This article serves as a central location for all links to troubleshooting documentation that has been published for Update Rollup 2 for Windows XP Media Center Edition 2005.  As new documentation is created, I will continue to add to this article.

Setup-related errors

Content protection errors

Guide download errors

Remote control and IR receiver errors

Digital Audio Service errors

Miscellaneous errors we have seen

Detailed information about Update Rollup 2 setup

 

  • My windows mce laptop with intel grpahics drivers is connected via s-video to an hdtv capable tv.  I can operate fine outputting to the hdtv EXCEPT when i go to media center.  

    I hear the media center welcome sound and then the tv goes black and no selections can be made.

    HELP!  I have seen this exact same problem on other forums with no successfull fix.

    Many thanks
  • Hi Brian - We have seen some issue with AVerMedia hardware, and we are working with them to try to encourage them to provide updated drivers.  In the meantime I'm not sure what to suggest.  I also don't know what to suggest for your 2nd issue about sound playback.

    Your 3rd issue sounds like the bug described at http://blogs.msdn.com/peterrosser/archive/2006/01/30/519576.aspx, and if so, that issue is a known bug that will be fixed in a future Media Center hotfix rollup package.  I'm sorry I'm not able to be more helpful here.
  • Thanks a ton for your help; that registry setting was exactly what was stopping it.

    I figured it was something like that holding it back and let's just say HP tech support was . . . unhelpful . . . (aka didn't have a clue what I was talking about).
  • Hi,
    I'm not absolutely sure this connects with Rollup 2, but my problem started shortly after.  I'm on Media Center 2005, and My live tv signal from my settop box, which was once great, suddenly became a signal that was now interrupted in 1 second intervals by a black screen.  TV show, black screen, Tv show, black screen.  Naturally it's annoying.  Recordings before are still fine, recordings now are like live TV.  If I apply cable directly from the wall, the live tv is fine.  I'm in Canada, and use Shaw systems for cable and I know they've installed an HDCP signal so I don't know if it's my set top box or the roll up 2.  Has anyone else seen this particular problem?  I've searched the net for the last 2 weeks but no one anywhere mentions this particular situation.  I had FINALLY a way to record my HDTV channels and now it's gone.  I'm finding myself getting so frustrated by this, I hope I'm not alone with this one.
  • Hi,

    I've got my television signal back normally.  My cable company set up a 'Video on Demand' option for my set top box and I lost my normal signal on my Media Center through the box.  After 2 or 3 weeks (I kept checking) the signal finally came back.  So sometimes I guess it's not fair to blame Media Center for problems that crop up.  THIS time it was something in the signal from my Set Top Box that screwed up Media Center.  What ever was wrong was corrected by my cable company.  Of course, maybe it was evil spirits or voodoo, these days what do I know?

    Just thought it might be of use to anyone else out there who may experience a similar problem.
  • How can I find out if Rollup2 was actually installed on my machine?  I was told that it was installed by the vendor (Monarch) but I can't find any evidence that it was.
  • Hi Dingo - This is a good question, and I posted a new item on my blog with the answer.  Please check out http://blogs.msdn.com/astebner/archive/2006/04/30/587290.aspx and let me know if you have any questions...
  • Hey everyone:

    I have a problem with my Windows Media Center. Everything works fine except that when I play a video or DVD in full screen mode, the image freezes and starts jumping (I call it the jumpng bean effect). I can still hear the audio of the video playing. All my video drivers are up to date and I've installed Power DVD 7 and Nero 7. Can anyone help????

    Jerry
  • Hmm...just went through a ton of the fixes on here...great stuff.

    I still have one minor but really annoying issue. Once I install the rollup 2 update, the actual selection sound in Media Center is very fuzzy/scratchy (I.E. you can scroll up and down in my music and you will get the little beep beep beep as you scroll crystal clear, but the noise you get when you actually click to select an artist for example sounds terrible). If you uninstall Rollup 2 it goes away. Just wondering if anyone else has experienced this/heard of this?
  • When I try to install this roll up I get the following errors in the log file and have no clue where to go from here:

    [KB914548.log]
    0.359: ================================================================================
    0.359: 2006/05/17 15:00:12.546 (local)
    0.375: c:\5ff5f15e11d0aa2b8692504d81eae658\update\update.exe (version 6.2.29.0)
    0.406: Hotfix started with following command line:
    0.796: Return Value From IsMediaCenterPC = 1
    0.796: IsMediaCenterPC returned value( 0x1 ) which is Equal To 0x1
    0.796: Condition succeeded for section PreReq.SingleOp.MediaCenter in Line 1 of PreRequisite
    0.796: SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Ident is Not Equal To Specified Value
    0.796: Condition Check for Line 2 of PreRequisite returned FALSE
    0.796: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.796: KB914548 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB914548 failed. For More details check the Log File c:\windows\KB914548.log
    0.828: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.828: Setup cannot continue because one or more prerequisites required to install KB914548 failed. For More details check the Log File c:\windows\KB914548.log
    13.250: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB914548 failed. For More details check the Log File c:\windows\KB914548.log
    13.250: User Input: OK
    13.250: Update.exe extended error code = 0xf0f4
    13.250: Update.exe return code was masked to 0x643 for MSI custom action compliance.
  • Hi Walt - The error that is causing this setup to fail is the following:

    SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Ident is Not Equal To Specified Value

    Can you check and see what the exact value is for HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Ident on your system?  The KB914548 hotfix has a prerequisite that Update Rollup 2 for Media Center 2005 be installed, and Update Rollup 2 should set the Ident value to be = 4.0.

    If you do not already have Update Rollup 2 installed, please try to install it first from http://www.microsoft.com/downloads/details.aspx?FamilyId=E5DAF37E-E243-4410-BC51-81CF2B56FE6E&displaylang=en and then try to install KB914548 again.
  • Guys! I got problem! I can't seem to successfully ROLLUP to the 2nd version!

    i get an error saying it had failed?

    "unable to install Update Rollup 2 for Windows XP Media Center Edition 2005 (KB900325)"

    Any ideas?
  • Thanks for the help. The ID was set to 3.1
  • Hi SABE - Can you please use the instructions listed at http://blogs.msdn.com/astebner/archive/2005/10/16/481689.aspx to gather and send me the log files from Update Rollup 2 setup so I can try to take a look and see if I can figure out what is causing this error?
  • Hi, after installing this update on a HP Pavilion DV8235NR laptop and launching media center, I get a ehExtHost.exe - Common Language Runtime error. Everything still works but the annoying error message comes up. Is there a fix for this? Thanks!
Page 4 of 8 (110 items) «23456»
Leave a Comment
  • Please add 8 and 7 and type the answer here:
  • Post