Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

How to short a Media Center remote control if it stops working correctly

How to short a Media Center remote control if it stops working correctly

  • Comments 56

A couple of months ago, I posted a list of workarounds that have proven useful to resolve problems using the Media Center remote control and IR receiver after installing Update Rollup 2 for Media Center 2005.

Since I posted that, I have received several comments from customers who were able to solve this issue with a different workaround not previously listed on that post.  I have found that internet searches do not do a great job of indexing blog comments, but they do well for the main body text of blog posts, so I wanted to post this suggestion as a separate blog post in the hope that others will be able to find it more easily.  I can't take any credit for finding this workaround.  It was posted as a comment on my previous blog post by a kind customer who discovered it and found it useful, and I have heard from several additional customers who indicated that it has helped them as well.

I encourage you to try this workaround if you have already exhausted the list of suggestions located in my previous blog post and still have problems getting your Media Center remote control and/or IR receiver to work correctly.

Symptoms

  • Media Center only receives the first button press (for example - pressing up, up, up only goes up once, but pressing down, up, down, up will work correctly)
  • The IR receiver light does not blink when pressing a button
  • Pressing buttons on the remote do not have any effect

Workaround

Remove the batteries from the remote control and short the battery terminals using a small metal object such as a paper clip.

There is enough capacitance remote control circuit board to keep it alive for hours even after you remove the batteries. However, you can workaround this and drain the capacitors by shorting two of the adjacent battery terminals on the remote.   Different remotes have different configurations, so it is difficult to know \which two adjacent terminals are the ones wired to the circuit board (the other two are simply a short to connect one battery to the other).  Therefore, you should short both pair of adjacent terminals, which can be achieved by using a paper clip.  After that, re-insert the batteries and try to use the remote control again.

 

  • I'm no electrician. How does one short the remote with a paperclip?
  • By shorting the remote (i.e. completing the path for electrical current to travel), you allow the capacitors in the remote to discharge.
  • I have tried everything listed here (shorting the remote and trying to reprogram the remote with DVD Menu and 1-5) but the remote still will not work. The receiver is listed in Device Manager and is installed properly and when I press a button on the remote, the receiver blinks. However, nothing happens. None of the buttons work. I am using MCE Version 2002 (SP2).
  • Have you heard anything about the remort shorting being a very temporary solution?..

    When the remote stops working, I can short the terminals and get the remote to work again. But for one click only. Then the remote needs to be shorted again.
  • Hi Chris - Have you tried all of the other workarounds listed at http://blogs.msdn.com/astebner/archive/2005/10/24/484423.aspx (and not just the channel 1-5 reprogramming suggestion)? If not, could you please try the rest of those suggestions and see if any of them help here?

    Hi BG - I haven't yet heard of this issue being temporary and recurring after every click like that. Just to make sure, have you tried the other workarounds that I listed at http://blogs.msdn.com/astebner/archive/2005/10/24/484423.aspx as well?
  • Hi Aaron
    I have the MS Media Center remote and I probably have to short the battery terminals 3 times a day. I've showed my wife how to do this, but she's not too happy about it :)
    Is there a root cause for this problem, or a long term solution?
    It seems the remote just regularly "crashes" (for lack of a better word)
  • Hi BG and James - I asked around for more details about this scenario, and I was told that this problem is due to a build-up of static electricity. It causes a short in the remote control IC and the battery terminal trick resets the unit, but then it can start to build up again, which will require another reset.

    If you need to reset this often to keep your remote working, you may want to explore getting a replacement remote. You should be able to obtain replacments from the distributer where you purchased your hardware.
  • Thanks Aaron
    It is really cool to have a resource like your site on the web.
    Thanks. Keep up the good work.
  • Thanks Aaron I think it was combination of the buildup and dead battery. Swapped out the one bad battery and things are groovy again. I must have mixed up one of the dead batteries with one of the good batteries the last time i replaced them. Thanks for your efforts though!
  • Thank you so much for this solution. I wish I could send you the money I would of spent on a new remote. This would of been the second remote I returned.

    Thanks again. I had the thing apart and everything. Nothing worked. I shorted the terminals with foil and everything is working great again!!

    Great site!
  • I have a similar problem in that my media center only accepts the first time I press a button until I press another then it will accept the button again. I'm using a Dell PDA running remote II software and it works fine on my amplifier. any ideas?
  • Hi Ian - you might want to try the most recent IR rollup package available at http://www.microsoft.com/downloads/details.aspx?FamilyID=b39d53f1-0ac9-433b-b488-4cab82f31dc8&DisplayLang=en and see if that helps here.
  • I have installed that and it seems to make little difference, my normal remote control works fine, as it always has, just the PDA that is playing up.

    I have installed TweakMCE and enabled the "universal remote control" option. still the same result
  • My problem is that i'm unable to use the back function of the remote, the stop, play, frw and rwd.

    I fixed the problem by reinstalling the remote drivers!
  • Hi Ian - Can you please also try the workaround suggestions listed at http://blogs.msdn.com/astebner/archive/2005/10/24/484423.aspx and see if any of those help at all?

Page 1 of 4 (56 items) 1234
Leave a Comment
  • Please add 6 and 5 and type the answer here:
  • Post