Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

New hotfix available to fix protected content playback errors in Update Rollup 2 for Media Center 2005

New hotfix available to fix protected content playback errors in Update Rollup 2 for Media Center 2005

  • Comments 11

As many of you have noticed and posted on my blog in the past (here, here, here and here), there are some problems in some cases related to playing back protected content after installing Update Rollup 2 for Windows XP Media Center Edition 2005.  In some cases, workarounds could be applied to allow playback to start working again, but they would cause a loss of pre-existing digital rights management (DRM) licenses.

Today, we have released hotfix KB913800 that is designed to fix the currently known root causes of protected content playback errors.  In addition, it should fix them in such a way that preserves pre-existing licenses you may have previously acquired.  If you are experiencing any errors playing back protected content in Windows Media Center after installing Update Rollup 2, please download and install this hotfix.

Please note that this hotfix is currently only available on the Microsoft Download Center, but it should be made available via Windows Update in the future.  You can find more information about this hotfix in this knowledge base article, including symptoms of the problem, possible root causes, a list of affected files, and a link to download the package from.

The Microsoft DRM and Media Center teams are very interested in hearing about your experiences with this hotfix package.  Please post comments on this blog post or use my blog contact form and let us know what issue(s) you have been seeing and whether or not the hotfix installs successfully and solves the issue(s).

 

  • I have Update Rollup 2, and KB913800 installed. I can play most protected content, but not wmv files that came preinstalled- such as an Alanis Morissette or 'Mysteries of the Nile(Hi-def)' videos. Still get this message:
    "To play this content you must acquire a license from the provider at:
    http://localhost/licerror.aspx

    No big loss, but it is curious.
  • Today is the monthly release of new hotfix packages and updates to Windows Update, and there are a couple...
  • I have the same problem the wav files won't play and the localhost/licerror link doesn't work.
  • I still have the problem on a MCE 2005 Rollup 2 system.

    The problem is that I cannot individualize the PC anymore even after cleaning DRM (folder or using CleanDrm.exe), installing Hotfix, start individualization from MS Web site ... Stucked !!
  • PingBack from http://blogs.msdn.com/astebner/articles/487537.aspx
  • I also have the localhost problem - but is this more to do with the way the video samples have been protected rather than with MediaPlayer?
  • Hi David and Jason - From what I've been able to find out, the localhost error is related to the way that the video samples that came pre-installed on your computer were protected as opposed to the underlying DRM functionality on your system.  Typically when that error happens, it means that DRM does not have a license for the file and it is trying to re-acquire it.  I am not sure the exact correct fix for that scenario though.  I have heard that you can insert your original installation media and reinstall the files or try to playback the files and it will repair the licenses, but I haven't been able to verify that personally.
  • After some excellent support from Evesham http://www.evesham.com/ a rebuild of the machine and a raft of fixes applied in the right order has fixed this issue. Happy to share the lengthy instructions to anyone who asks (davidslight@hotmail.com)
  • This article serves as a central location for all links to troubleshooting documentation that has been

  • I also seem to have the problem... although in my case I didn't notice it until I installed WMP 11. I don't know about any of you, but I don't have a file called licerror.aspx on my system. The error seems to have to do with the preinstalled sample files DRM, but I can't verify that any other DRM protected files(other than copy-protected rips) work or not seeing as I don't have any. :) I would have thought any WMP 10 fixes would have been fixed for WMP 11 but I guess not. I am going to see if I can find the original files on the install cd's and see if that works.

  • All are tech stuff and no easy fixes, will check back. shouldnt be ths difficult.

Page 1 of 1 (11 items)
Leave a Comment
  • Please add 5 and 7 and type the answer here:
  • Post