Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

How to install and run the My Movies add-in in Windows Media Center on Windows Vista

How to install and run the My Movies add-in in Windows Media Center on Windows Vista

  • Comments 1

After I posted my blog entry this past weekend about problems installing the My Movies add-in on Windows Vista, I was able to get in touch with Brian Binnerup, the developer who wrote this add-in (thanks to an introduction from Charlie).  It turns out that Brian has also posted a detailed set of instructions that can be used to install and run My Movies with Windows Media Center for Windows Vista.

While I was helping to investigate the bug reports we'd received about the My Movies add-in, I used instructions very similar to the ones Brian posted to install My Movies on a test system in my office.  Therefore, I can confirm that these instructions work as listed.

You will see some odd behavior during the .NET Framework 1.1 and 1.1 SP1 setup where Windows Vista reports compatibility problems.  The .NET Framework 1.1 will work fine on Windows Vista, but you do need to make sure that you install 1.1 SP1 in order to fix some known issues that were in the original version of 1.1 but fixed in SP1.  You will also see a dialog for the .NET Framework 1.1 SP1 stating that it is also incompatible, but this particular dialog is a bug (you'll notice that it reports that you must install SP1 to fix this issue, but yet that is the product you're currently trying to install).

One note here - Brian's steps include disabling User Account Control (UAC) on Windows Vista.  The UAC feature is designed to enhance security by preventing unauthorized programs from making changes to protected resources on the system.  You should not need to globally disable UAC in order to run Windows Media Center and use My Movies.  Instead you should be able to leave UAC enabled and launch Windows Media Center with elevated privileges by using the following steps:

  1. Open Windows Explorer and navigate to %windir%\ehome
  2. Right-click on the file ehshell.exe
  3. Choose Run as administrator

<update date="7/15/2010"> Fixed broken link to the My Movies site. </update>

Leave a Comment
  • Please add 1 and 1 and type the answer here:
  • Post