Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

.NET Framework 3.0 hotfix (KB932471) will fail to install if .NET Framework 3.5 beta 2 is installed

.NET Framework 3.0 hotfix (KB932471) will fail to install if .NET Framework 3.5 beta 2 is installed

  • Comments 9

Recently, we have been hearing reports from customers who have installed the .NET Framework 3.5 beta 2 and then visited Windows Update and were offered .NET Framework 3.0 hotfix KB932471, but it continually fails to install.

The .NET Framework 3.5 contains an updated version of the .NET Framework 3.0, and that updated version of 3.0 contains this hotfix already.  Unfortunately, there was some incorrect detection information in the Windows Update logic that is used to decide whether or not to offer this hotfix to a system.

If you have the .NET Framework 3.5 beta 2 or later installed and run into issues while trying to install KB932471 (either from Windows Update or by downloading it directly from the Microsoft Download Center), you can safely ignore this failure and just skip installing this hotfix since the equivalent fix is already a part of the version of the .NET Framework 3.5 that you have on your system.

The Windows Update authoring logic that is causing this error is in the process of being fixed, and will be refreshed on the live Windows Update site in the near future.

Page 1 of 1 (9 items)
Leave a Comment
  • Please add 4 and 3 and type the answer here:
  • Post