Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

Version information that can help diagnose errors when opening XNA Game Studio projects in Visual Studio

Version information that can help diagnose errors when opening XNA Game Studio projects in Visual Studio

  • Comments 0

I recently noticed a blog article from the Zman that I wanted to link to here to hopefully make it easier to find.  The post, located at http://www.thezbuffer.com/articles/541.aspx, provides some behind-the-scenes details about the contents of XNA Game Studio and XNA Game Studio Express .csproj files.  The project GUIDs and XNA Framework version information listed in this post can help you determine exactly what version of XNA Game Studio or XNA Game Studio Express a specific .csproj file was created with.

If you run into an error message stating "The project type is not supported by this installation" when attempting to open an XNA Game Studio project in Visual Studio 2005 or 2008 and are trying to figure out how to fix it, the information in this article can be very helpful.  Typically, this error occurs when trying to open XNA Game Studio projects for one of the following reasons:

  • Trying to double-click an XNA Game Studio project (.csproj) file on a system that does not have the matching version of XNA Game Studio or XNA Game Studio Express installed.
  • Trying to open a project from within a version of Visual Studio that is not supported by the version of XNA Game Studio that the project was created in (for example - opening an XNA Game Studio 2.0 project in Visual Studio 2008).
  • Trying to open a XNA Game Studio Express 1.0 or 1.0 Refresh project on a system that has an up-level edition of Visual Studio 2005 installed but does not have Visual C# 2005 Express Edition installed - this will cause the solution to open in the up-level edition of Visual Studio 2005, but XNA Game Studio did not support up-level editions of VS until XNA Game Studio 2.0.  Projects for the 1.0 or 1.0 Refresh versions must be opened on a system that has Visual C# 2005 Express Edition and XNA Game Studio 1.0 or 1.0 Refresh installed.

If you run into an error while trying to open an XNA Game Studio or XNA Game Studio Express project on your system, I encourage you to check out this article and use the information listed there to determine the XNA Game Studio version of the project that you're trying to open by looking at your .csproj file in Notepad, then verify that the necessary versions of both Visual Studio and XNA Game Studio are installed on your system.

For reference, here is a list of supported Visual Studio platforms per version of XNA Game Studio:

Leave a Comment
  • Please add 6 and 8 and type the answer here:
  • Post