Aaron Stebner's WebLog

Thoughts about setup and deployment issues, WiX, XNA, the .NET Framework and Visual Studio

Possible installation issues with the Windows Phone Developer Tools January 2011 Update

Possible installation issues with the Windows Phone Developer Tools January 2011 Update

  • Comments 1

As I mentioned in a previous blog post, the Windows Phone Developer Tools January 2011 Update was released a few days ago.  Since then, I’ve heard from a few people who have reported installation issues that I wanted to describe in a bit more detail in case others run into them in the future.

Issue 1 – Windows Phone Developer Resources patch silently exits when it is done installing

The Windows Phone Developer Resources patch that is a part of the Windows Phone Developer Tools January 2011 Update only displays a small dialog with a progress bar during the installation process.

The installation process can take a long time on some computers because it needs to re-generate the saved state file for the updated emulator image, and it may appear to be hung with the progress bar registering 100% complete while it does this.  You should not not try to close setup or kill it with the Task Manager during this time. 

When the installation process completes, the small dialog with the progress bar disappears, but there is no indicator that setup is complete or that it succeeded.  You can determine whether or not this patch successfully installed by doing the following (this is copied from the January 2011 Update release notes):

  1. Go to the Programs and Features control panel (you can get to this quickly by typing appwiz.cpl in the Start menu search bar).
  2. On the left side of the Programs and Features control panel, click the link named View installed updates.
  3. If the update installed successfully, you will see Microsoft Windows Phone 7 Developer Resources - January 2011 Update in the list of installed updates.

Issue 2 – Visual Studio patch fails on a system that has the Visual Studio 2010 SP1 beta installed

The Visual Studio patch that is a part of the Windows Phone Developer Tools January 2011 Update will not install correctly if the computer it is being installed on has the Visual Studio 2010 SP1 beta installed.  If you have the Visual Studio 2010 SP1 beta, you will need to uninstall it and then use the following steps to restore Visual Studio 2010 before you can install the Visual Studio patch:

  1. Go to the Programs and Features control panel and uninstall the item named Microsoft Visual Studio 2010 Service Pack 1.
  2. Run setup.exe from the location that you originally installed Visual Studio 2010 from.  If you are prompted by User Account Control to elevate, click Continue.
  3. Click Change or Remove Microsoft Visual Studio 2010.
  4. Once setup finishes loading, click Next.
  5. Click Add or Remove Features.
  6. Re-check any of the features you want to repair. If the features that you want to repair are already checked, you will need to uncheck and recheck them.
  7. Click the Update button.
  • I had similar issues: the progress bar registered 100% complete for almost two hours! However, already after one hour the system no longer seemed to be working. For this reason I have finished the process, I rebooted the system by disabling all non-Microsoft services and ran the update again: in less than twenty minutes the update was completed... In order to determine whether or not this patch is successfully installed, I checked Microsoft Windows Phone 7 Developer Resources - January 2011 Update in the list of installed updates.

    There might be some trouble stopping the process during the first attempt to install?

    Thanks a lot!

Page 1 of 1 (1 items)
Leave a Comment
  • Please add 2 and 3 and type the answer here:
  • Post