Couple of times we saw the issue while running axsetup.exe to install Enterprise Portal that is failing with error:

Entering function CurrentUserAlias
Leaving function CurrentUserAlias
Creating new Enterprise Portal Site with following the parameters:\n URL: http://daxtstep.exnet.sas.com/sites/DynamicsAx\n Title: EP Site\n LCID: 1033\n OwnerLogin: CARYNT\spdax
Administration Web Service URL: http://daxextst01:10000/_layouts/ep/WSSAdmin.asmx
An error occured while Setup was creating a new site.
Exception of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown.
User cannot be found.0x80131600
Exception of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown.

System.Web.Services.Protocols.SoapException
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at Microsoft.Dynamics.Framework.Deployment.Portal.WSSAdmin.CreateSite(String Url, String Title, String Description, Int32 Lcid, String WebTemplate, String OwnerLogin, String OwnerName, String OwnerEmail, String PortalUrl, String PortalName)
    at Microsoft.Dynamics.Framework.Deployment.Portal.EPDeployment.CreateDefaultEPSite(String virtualServerUrl)

 

To overcome this issue we need to:

Make sure that Central Administration service is running as internal user domain account. To change Central Administration account you can use following procedure (also applicable for SharePoint 2010)

http://technet.microsoft.com/en-us/library/cc288991(office.12).aspx