Français English
La beta 2 refresh de Windows Server AppFabric est compatible avec la version RTM du .NET Framework 4.0.
Elle est disponible à http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=8197ad8d-673f-4efb-b165-82710f2648c3
Pour effectuer la mise à jour, il faut désinstaller l’ancienne version. Dans Programs and Features, sur un Windows Server 2008, on ne trouve pas l’installation de “Application Server Extensions for .NET 4 (KB970622)”. Pour le voir, il est nécessaire de montrer les mise à jour des différentes fonctionnalités (“View installed updates”), car l’installation de Windows Server AppFabric est une mise à jour de Windows.
Windows Server AppFabric Beta 2 Refresh is compatible with the RTM version of the .NET Framework 4.0.
It’s available at http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=8197ad8d-673f-4efb-b165-82710f2648c3
In order to upgrade, you must first uninstall previous version. In Programs and Features screen on Windows Server 2008, you won’t find “Application Server Extensions for .NET 4 (KB970622)” until you select “View installed updates” because Windows Server AppFabric installation is an update of Windows Server.

Programs and features with App searched and updates displayed

 

A partir de là, il est possible de désinstaller l’ancienne version, avant d’installer la nouvelle.

Si vous avez déjà désinstallé la version du .NET Framework sur laquelle s’appuyait la version existante de Windows Server AppFabric à désinstaller, ce billet est votre ami: http://blogs.technet.com/appfabric/archive/2010/03/05/uninstalling-windows-server-appfabric-beta1-after-vs-10-beta2-net-framework-4-beta2-has-been-uninstalled-or-post-vs-10-rc-install.aspx

Une fois l’ancienne version désinstallée, vous pouvez installer la version beta 2 refresh au dessus du .NET Framework 4.0. La page de téléchargement comprend un guide d’installation également.
From there, it is possible to uninstall previous AppFabric version, before installing the new one.
If you’ve already uninstall the previous version of .NET Framework 4.0 on top of which Windows Server AppFabric vn-1 was installed, then the following blog post is your friend: http://blogs.technet.com/appfabric/archive/2010/03/05/uninstalling-windows-server-appfabric-beta1-after-vs-10-beta2-net-framework-4-beta2-has-been-uninstalled-or-post-vs-10-rc-install.aspx

Once previous version of AppFabric is uninstalled, you can install beta 2 refresh version on top of the .NET Framework 4.0 RTM. Download page also contains an installation guide.

image

image