Here’s an interesting behavior I saw being discussed that you may run into when launching the PPS add-in for Excel when you have (or not) language packs installed:

The PerformancePoint Add-in for Excel could not be loaded. The language pack for the configured language could not be found. Please install the multilingual user interface pack for your version of Office or set the operating system locale to the same locale as that set for Office

The add-in always wants to see that the regional settings of your operating system and Office are the same. OK, good so far. The add-in also expects (I’m not sure why) those settings to use the core language, too. In other words, German (Germany) or Spanish (Spain) are good, but German (Austria) and Spanish (Peru) are not – stinks if you’re in Peru or Austria, eh?

Never fear, because there’s a workaround can you use to deal with the behavior above -  Just make sure that you have the language packs for both locales (German (Germany) and German (Austria), for example) installed on the machine. You can use http://www.microsoft.com/globaldev/reference/win2k/setup/lcid.mspx for locale-specific information, by the way.

…But what happens if the locale you want to use, like German (Austria) doesn’t even have a language pack? Well, there’s a solution for that, too:

1.       Install the language pack for your “core” language on the machine in question – German (Germany) will lay down C:\Program Files\Microsoft Office\Office12\1031

2.       Create a copy of the folder above (including all the files inside it), and then rename it to the correct LCID value (use the link above to determine what the value is). For German (Austria) we’d create C:\Program Files\Microsoft Office\Office12\3079.

At this point, you should be in pretty good shape.