There have multiple requests from customers seeking for clarity on the applicability of the leap year fix http://support.microsoft.com/kb/2435900.

If you are not using X12 in your EDI transactions, this issue is not applicable to you and hence you dont have to worry about taking this fix at this time.  The fix is only on the x12 code path and does not affect EDIFACT processing.

Please to my earlier post for a repro sample.

PS:  Please ensure that you have Biztalk 2006 R2 SP1_CU3 "before" applying this fix.  The fix is a later build after CU3 and has certain engine binaries that have updates/dependancies on earlier builds. 

Please reach out to Biztalk Support team if you need any assistance in installing SP1 or CU3.

Thanks
Guru