Last week we announced our plans for Prism 4.0 on patterns & practices blog, David Hill’s blog, and my blog. A number of you asked a follow-up question if Prism 4.0 will support Unity 2.0. The answer is yes? When we publish the interim release for WPF 4.0 and Silverlight 4.0, we will also ensure it runs on Unity 2.0. If you need to use Unity 2.0 with Prism before the release, this knowledge base article on Codeplex will help you migrate.