My first experience with hyper-V (Few BIOS setting)

My first experience with hyper-V (Few BIOS setting)

  • Comments 6

I decided to write a new blog series to Install SQL Server 2008 on Windows 2008 cluster in Virtual environment. Since I got brand new Windows 2008 64 Bit machine, i decided to use Hyper-V to play around. I could install Hyper-V without any issue but I saw below series of error in Event log

Erro1: Hyper-V launch failed; Either VMX not present or not enabled in BIOS.
Error2: Hyper-V launch failed; at least one of the processors in the system does not appear Error3: to provide a virtualization platform supported by Hyper-V.
Hyper-V launch failed; No-execute (NX) or DEP not enabled on processor 0x0 (check BIOS settings).

All of them were pointing to something wrong with BIOS setting. My search to internet ended in many links but finally I could make it work by setting below in BIOS settings on my DELL machine. (below specification)

System Model    OptiPlex 755

Processor    Intel(R) Core(TM)2 Duo CPU     E6550  @ 2.33GHz, 2327 Mhz, 2 Core(s), 2 Logical Processor(s)

  1. Security > Execute Disable (set to On)
  2. Performance > Virtualization (set to On)
  3. Performance > VT for Direct I/O Access (set to On)
  4. Performance > Trusted Execution (set to Off)

After making above changes, I rebooted the machine and then I was able to use Hyper-V and create new virtual machine.

Stay tuned, I am starting my work to new blog series to install SQL 2008 Cluster on Windows 2008 Cluster.

Leave a Comment
  • Please add 6 and 6 and type the answer here:
  • Post
  • Thanks. You need to enable Data Execution Prevention and Virtualization Technology (VTx) on HP machines :)

  • Hi Akshay,

    Could you please provide me more details about where to enable it?

  • I could successfuly start Hyper-V machine after reading this Blog, Thank you very much!

    System Model    OptiPlex 755

    Processor    Intel(R) Core(TM)2 Quad CPU     E6770  @ 2.40GHz

    ** My BIOS Version is A13 (latest at this time) **

    ** on Windows Server 2008 R2

    Security > Execute Disable (set to On) <-- This was OFF

    Performance > Virtualization (set to On)

    Performance > VT for Direct I/O Access (set to On)

    By the way, the following option doesn't exist in my BIOS (maybe due to the version A13)

    Performance > Trusted Execution (set to Off)

  • Thanks, blakhani, Thanks for your share, I am building  SQL Server 2008 Cluster, too, hope we can share experiences to each other, feel free to contact me. MSN:boweiqiang@163.com

  • Thanks Weiqiang Bu for the comment. I would love to hear experience you had with setup.

  • @blakhani: regarding for HP servers you can check at

    h20000.www2.hp.com/.../Document.jsp

Page 1 of 1 (6 items)