Prism Source Updated for Unity 2.0 and Silverlight 4

Prism Source Updated for Unity 2.0 and Silverlight 4

  • Comments 1

We’re getting started with our Prism v4 work, but we have received a number of inquiries regarding updating the source to use Unity 2.0 and Silverlight 4.0.  To help those interested in using Prism with these latest releases, we’ve updated the source in the Codeplex repository.

The changes are:

  • All projects updated to Visual Studio 2010
    • All test projects now target .Net 4.0
    • Note: The WPF library projects still target .Net 3.5
  • All Silverlight projects update to target Silverlight 4.0
  • Prism is updated to use the latest Unity 2.0 binaries.
  • The Reference Implementation uses the latest Unity 2.0 and Enterprise Library 5.0 binaries.
  • The Silverlight Reference Implementation now uses the latest binaries from the Silverlight Toolkit (primarily for charting).

This update does not include converted Quickstarts or a VS2010 version of the ProjectLinker.

While the code is largely unchanged, we have only done light smoke testing on this after the updates so use at your own risk.  If you do encounter any problems with these updates, let us know.

  • I just installed Enterprise Library 5.0 but was disappointed in the lack of a "place binaries in the GAC" option.  Why is Enterprise Library released without an automatic way to put the binaries in the GAC?

Page 1 of 1 (1 items)
Leave a Comment
  • Please add 2 and 8 and type the answer here:
  • Post