SP2013 State Service Required for Search

SP2013 State Service Required for Search

  • Comments 2

I had configured my farm without using the wizard – like any good SharePoint Administrator should do. Everything was working great as far as I could tell; I had User Profiles, Taxonomy, Search, the entire Social experiences, email… everything.

As I was setting up for a demo to my customer, I was clicking around the Search Admin pages and noticed the following:

image

“The chart cannot be rendered. This may be due to a misconfiguration of the Microsoft SharePoint Server State Service. For more information, contact your server administrator.”

It just so happens in my environment that I had never configured the state service, but I searched around and even though I see several points of data that show you how to configure the state service when you are configuring the farm manually I never saw anything that said Search requires the state service for reports. Maybe it should be a given, but in my case everything seemed to work until I got to this point.

After configuring the state service, I was then able to get reports from Search:

image

Leave a Comment
  • Please add 3 and 7 and type the answer here:
  • Post
  • I had the same issue today...open a SharePoint Management Shell as Administrator and enter the following commands:

    PS C:\>$serviceApp = New-SPStateServiceApplication -Name "State Service Application"

    PS C:\> New-SPStateServiceDatabase -Name "StateServiceApplicationDB" -ServiceApplication $serviceApp

    PS C:\> New-SPStateServiceApplicationProxy -Name "State Service Application Proxy" -ServiceApplication $serviceApp -DefaultProxyGroup

  • great add-on, Wes, thanks!

Page 1 of 1 (2 items)