Cascade Skyline - with Microsoft Logo and Project Support header - author Brian Smith

Project Server 2010: An unknown error has occurred in Project Center, Resource Center or Tasks

Project Server 2010: An unknown error has occurred in Project Center, Resource Center or Tasks

  • Comments 10

Thanks to my friends at one of our great TAP partners for this resolution. I love it when customers solve their own problems, and love it even more when they tell me about it so I can tell you.  Happy to give them credit for the resolution too – but only when I hear back from them that they are ok with the glory… ***Update *** and have the all clear to name Accenture, and Kranti Deshpande.  Thanks for all you work on the TAP and beyond!

The error is in red text where the grid should be – and isn’t a normal pop-up that you’d expect from SharePoint, but just text.  This appears on the Project Center, Resource Center and also Tasks and Timesheet pages

image

No scripts errors, but I did find some useful things in the Event Log when I reproduced the error.  I have copied this at the foot of this blog – mainly there for the search engines, but Event ID 3, WebHost is the important piece. Nothing jumped out at me from the ULS logs – I think this is more an IIS to client issue rather than SharePoint – but I did see some http binding messages (BasicHttpBinding) at about the right time

The issue was that in IIS Manager the Authentication for the site was set to use Windows Authentication, but in the Advanced Settings, Extended Protection was set to a value other than Off.

image

Just setting back to Off resolved the issues – and no IISReset required.

And for the search engines – the error…

Log Name:      Application
Source:        System.ServiceModel 3.0.0.0
Date:          7/2/2010 3:44:42 PM
Event ID:      3
Task Category: WebHost
Level:         Error
Keywords:      Classic
User:          domain\user

Computer:      servername
Description:
WebHost failed to process a request.
Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/19339735
Exception: System.ServiceModel.ServiceActivationException: The service '/_vti_bin/PSI/ProjectServer.svc' cannot be activated due to an exception during compilation.  The exception message is: The extended protection settings configured on IIS do not match the settings configured on the transport.  See inner exception for details.. ---> System.NotSupportedException: The extended protection settings configured on IIS do not match the settings configured on the transport.  See inner exception for details. ---> System.InvalidOperationException: The ExtendedProtectionPolicy.PolicyEnforcement values do not match.  One policy has a value of Always, while the other has a value of Never.  These values must match exactly.
   --- End of inner exception stack trace ---
   at System.ServiceModel.Channels.HttpChannelListener.ApplyHostedContext(VirtualPathExtension virtualPathExtension, Boolean isMetadataListener)
   at System.ServiceModel.Channels.HttpTransportBindingElement.BuildChannelListener[TChannel](BindingContext context)
   at System.ServiceModel.Channels.BindingContext.BuildInnerChannelListener[TChannel]()
   at System.ServiceModel.Channels.MessageEncodingBindingElement.InternalBuildChannelListener[TChannel](BindingContext context)
   at System.ServiceModel.Channels.TextMessageEncodingBindingElement.BuildChannelListener[TChannel](BindingContext context)
   at System.ServiceModel.Channels.BindingContext.BuildInnerChannelListener[TChannel]()
   at System.ServiceModel.Channels.Binding.BuildChannelListener[TChannel](Uri listenUriBaseAddress, String listenUriRelativeAddress, ListenUriMode listenUriMode, BindingParameterCollection parameters)
   at System.ServiceModel.Description.DispatcherBuilder.MaybeCreateListener(Boolean actuallyCreate, Type[] supportedChannels, Binding binding, BindingParameterCollection parameters, Uri listenUriBaseAddress, String listenUriRelativeAddress, ListenUriMode listenUriMode, ServiceThrottle throttle, IChannelListener& result, Boolean supportContextSession)
   at System.ServiceModel.Description.DispatcherBuilder.BuildChannelListener(StuffPerListenUriInfo stuff, ServiceHostBase serviceHost, Uri listenUri, ListenUriMode listenUriMode, Boolean supportContextSession, IChannelListener& result)
   at System.ServiceModel.Description.DispatcherBuilder.InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost)
   at System.ServiceModel.ServiceHostBase.InitializeRuntime()
   at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
   --- End of inner exception stack trace ---
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
   at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
Process Name: w3wp
Process ID: 4580

Technorati Tags: ,
Leave a Comment
  • Please add 8 and 1 and type the answer here:
  • Post
  • I have the same issue... I´ll try to fix with your solution ...Thanks :D

  • I found that this error also occurs if the view uses a EPM code in filter or group that no longer exists.

  • I can confirm that the reason that when opening the Project Center the message an unknown error has occured is solved by removing the categories for the Project Center views or deleting the views that are causing the issue. I had 10 Project Center views, I removed for every view the categories, so they are not shown in the project center. I created a new Project Center view that worked fine. The view that was causing an issue had a filter on Project Type.

  • More details after more testing...

    The problem occurs only when filtering on an "outline code" such as Project Status (open, close...) and the built-in Project Service. It works when I filter on a free text, number or date field.

    I tried to include the filtered field in the view. Still have the problem.

    I tried to filter the view on a custom outline code AFTER it is loaded in the Project Center. That works. It looks like there is a filter interpretation issue on the view preparation process.

    Note that I use a French (1036) environment.

  • I have the same issue but only for one resources at My Task view.

    Any idea how to fix it ?

    Thanks

    Pnina

  • Hi Pnina, if it only happens for one user then you don't have the same issue (and the same as the blog posting?  Or the comment above?) - just the same error message - unknown.  Best to check the ULS logs - but depending on what that user is viewing and filtering on - compared to other users it may be an issue we have fixed with the recent hotfix KB support.microsoft.com/.../2598251 - not live as I write but coming shortly.  This is also included in the Project Server 2010 roll-up package that came out late and so was also able to include this fix support.microsoft.com/.../2597152 (The 6117.5002 build). You will need to clean up any existing duplicate custom field values (the underlying reason for the problem) so contact support if the KB is still not live.

    Best regards,

    Brian.

  • Brian -  I am researching this issue for our MSPS 2010.   This error (and unknown error has occurred) only appears with a select group of people when accessing their TASKS Page in PWA.   Does this mean it may be schedule related?    Can you point to a specific hotfilx or KB that may help me narrow the answer down (as I am finding a slew of information that is all over the board for this error).    Thank you!  ~RK

  • Hi Randy, best to look at the ULS logs for when the error occurs - this will give a more precise error.  No specific KB without knowing more - but yes, likely related to specific tasks in the schedule in some way.

    Best regards,

    Brian.

  • Hi Brian, great post.

    But let me show you this post to show another solution for another problem but with the same notification in the section "My Task" with "An Unknow Error has occurred"

    In this post

    social.technet.microsoft.com/.../an-unknown-error-has-occurred-project-server-2010-tasks-page

  • As the thread mentions Erick - there can be different root causes that give the same symptom.  Glad you found yours and I am sure it will help others.

    Best regards,

    Brian.

Page 1 of 1 (10 items)