Cascade Skyline - with Microsoft Logo and Project Support header - author Brian Smith

Project Server–Do I need to keep the client and server at the same release level?

Project Server–Do I need to keep the client and server at the same release level?

  • Comments 0

We get this question quite a bit – and to be clear I am only talking about the Service Packs and Cumulative Updates – we do not support Project Professional 2010 connecting to Project Server 2013 or Project Professional 2013 connecting to Project Server 2010.  But do I need to have my client at the same Cumulative Update level as my server?  Or if I update the server (Project Server 2010 or Project Server 2013) then do I also need to update the client software (Project Professional 2010 or Project Professional 2013).  There is no requirement to do this – any Cumulative Update (CU) or Service Pack (SP) level of the client will work with any CU or SP level of the server.  That said you may wish to be at least at a certain level for all clients that connect to your server to avoid certain issues that we have fixed – so it is not a bad idea to control this through the Server Settings options.  Our support lifecycle also requires certain patch levels to be in use – for example the initial release of Project 2010 went out of support around a year after SP1 was released.  I know certain consultants and partners tend to keep versions in sync as a ‘best practice’ – and certainly it is not wrong to do this – but nothing will break if you don’t.  In the very rare circumstance that we released a fix that affected both client and server and required that both were patched then we would document this in the KB article.

Leave a Comment
  • Please add 6 and 8 and type the answer here:
  • Post