Q1) Can we install VS 2008 "Orcas" side-by-side with VS 2003 and VS2005?

A1) Yes - they will run side-by-side. If you face any specific issue during installation or while using - please let me know by leaving a comment here.

Q2) What is the version of framework that ships with the VS 2008 "Orcas"?

A2) VS 2008 ships the .Net Framework 3.5 with it. The .Net 3.5 is an extension to the .Net 3.0 that was shipped along with Vista release. The 3.0 (which as also called WinFx in the early days) had introduced/added components like the WPF, WCF, WF and CardSpace to the existing framework (.Net 2.0). .Net 3.5 adds things like - the new language features of C# and VB.NET, LINQ, BigInteger etc. Having said this - it is important to mention that the core runtime still stays the same (there is no new mscorwks.dll). So when you install Orcas on a fresh machine the .Net 2.0, 3.0 and 3.5 all will be installed.

Q3) Can i build application only for .Net 3.5 using VS 2008 "Orcas"?

A3) No. You can target all three frameworks - .Net 2.0, .Net 3.0, .Net 3.5. (Sorry no support for 1.0 or 1.1). Also, you cannot mix frameworks in the same application.

Q4) Will I be able to use C# 3.0 to compile assemblies for .NET Framework 2.0?

A4) Thanks to Daniel for correcting me on this. Yes you can. Please refer to his blog post: http://www.danielmoth.com/Blog/2007/05/using-c-30-from-net-20.html

Q5) Do we have a 64-bit version of VS 2008 "Orcas"?

A5) No, VS 2008 "Orcas" will run on 64-bit OS as a 32-bit process under WOW. But you can use VS 2008 "Orcas" to build and target the 64 bit OS.

Keep tuned to this post - i'll be editing this as things come by…