Beta 1 for TFS 2010, along with VS and VSTS, is now available to MSDN subscribers and will be available for broad download shortly.  Be sure to check out the Microsoft Visual Studio 2010 First Look site to see what’s in this release, as well as the documentation on MSDN.  Brian has written posts on TFS 2010 features in administration and operations and work item tracking so far.

There’s a bug you’ll want to avoid in setting up and initially configuring beta 1.  If you choose not to continue on through configuration at the end of the MSI setup phase (in other words, you uncheck the box to launch the configuration tool), you must finish configuration by running tfsmgmt.exe configure to avoid causing problems with SharePoint.  After you have initially configured the server, you can and should use the Team Foundation Administration Console to make changes to your server.  We believe it's a great feature, and we want your feedback on it.  It's just the initial configuration of the server where we have this issue.

Here's a screenshot with the checkbox I'm talking about.  You'll want to leave it checked and continue through the configuration wizard.

image

If you choose to uncheck the box and then run the Team Foundation Administration Console (Start –> All Programs –> Microsoft Team Foundation Server 2010 Beta 1 –> Team Foundation Administration Console), here is what you will see.  Do not click the link to run the wizard.  Instead, run the server configuration wizard from the command line via tfsmgmt configure instead.

image

If you go to the Team Foundation Build node in the admin console, you will see a similar link for configuring build.  There are no issues with configuring build from the admin console, so that one is not a problem.

Here is the content from the Beta 1 Readme about this issue, including the full path to the command line tool.

1.3.4   Initial Configuration of Team Foundation Server Should be Run From MSI Program or by Command Line

Initial Team Foundation Server configuration fails on Windows SharePoint configuration if you access the Team Foundation Configuration Tool by clicking the link in the Team Foundation Administration Console instead of by launching Team Foundation Configuration Tool at the end of the installation phase.

To avoid this issue:

If you want to setup Windows SharePoint Server during Team Foundation Server configuration, you must launch the Team Foundation Server Configuration Tool by using one of the two following methods:

·         Launch the Team Foundation Configuration Tool by selecting the check box at the end of the Team Foundation Server installation

·         If you exited Team Foundation Server MSI program (setup.exe) without launching Team Foundation Configuration Tool, do not start the Administration Console from the Start menu item shortcut. Instead use following command line:

"%programfiles%\Microsoft team foundation server 10.0\tools\tfsmgmt.exe" configure

After Team Foundation Server has installed and configured Windows SharePoint, you can configure Team Foundation Server by using the Start menu to launch Team Foundation Server Administration Console.

If you end up in a situation where you have installed beta 1 by launching the configuration wizard from the admin console and ended up with a corrupt SharePoint installation, the easiest way to get out of the situation right now is to uninstall both SharePoint and TFS 2010 and then re-install TFS 2010 Beta 1 and let it install and configure SharePoint.  I'll update this post if we have a set of steps that is less drastic than this.

This was a problem we discovered at the last moment.  It is due to the fact that we force the Microsoft Management Console (MMC), which hosts our Team Foundation Server Administration Console GUI, to run our MMC plugin under CLR 4.0.  The reason we had to do that is because MMC uses an older COM API to host the CLR, which is now capped at CLR 2.0 due to changes made in CLR 4.0.  The side effect of that hack is that it causes child processes that are executed to also run under 4.0.  One of the processes that we run as part of configuration is stsadm.exe.  Running stsadm under 4.0 causes it to serialize some 4.0 objects in the SharePoint database, at which point SharePoint is broken.

If you go straight through the setup and into configuration, thus following the default path, everything will work.  If you choose not to continue with configuration after the MSI portion of setup has completed, you need to run tfsmgmt.exe configure to complete the configuration (running it separately like that avoids the problem with the MMC environment).

Once you’ve gone through the initial installation and configuration of SharePoint, you can use the new Team Foundation Server Administration Console with no restrictions.

For beta 2 and beyond, we have made changes (yes, past tense…we’ve been working hard on beta 2) that avoid this issue entirely.

Be sure to provide us feedback and let us know what issues you find in beta 1 by entering them into Connect.

[Update 5/19/2008]  I've added a couple of screenshots to make it more clear, and I've also added clarification that it's the initial configuration of the server where you need to be aware of this issue.