When last we left our intrepid SBS Release Manager, he had been humbled at the all mighty task of trying to upgrade a pre-existing server box to be able to run SBS. After much consternation, he had gone off and gotten a BIOS upgrade for the machine, and re-scheduled a time to go back and perform the upgrade. We scheduled it for after work on a Tuesday, I knew this was risky, but my schedule on Wednesday was pretty light so I knew I could come in Wednesday morning to fix any glitches that came up.

I walked in confident; I walked in sure. This was going to fix it, we would be back on track and ready to go. I backed up the old BIOS (safety first), flashed the new BIOS (all went well), rebooted, inserted the new drives, powered the machine on, and.... nothing.

No change. Still not recognizing the drives. At this point I was super frustrated, and feeling bad that this CPA shop still had made no progress despite having purchased new drives and a new BIOS. What the hell was going on? I tried flipping around the cables and jumpers again, but I knew that couldn't be the problem. In desperation, they started pulling out all the hardware manuals for the machine, including the motherboard instruction book. Now who reads an instruction manual, especially for a motherboard?

Well thank God I did, because I happened to notice that this board had two different IDE channels. One regular IDE channel (primary and secondary) and then something called a PROMISE IDE channel (also Primary and Secondary). Who the heck had ever heard of this? Turns out this is some sort of IDE channel that's fairly common on Linux servers, but required a specific driver and blah blah blah, I'm too frustrated with the whole thing to go into it anymore. I reset the cables so the drives were set into the main IDE channels and Presto; everything works fine.

So we're finally able to start the SBS install. I knew this was going to take a while, so after waiting for the OS to install, and then CD1, once we had CD2 inserted, which I knew would take at least 40-45 minutes on this machine (it wasn't the swiftest server), we went out for dinner at a nice Chinese restaurant, where we happened to see our local Congressman, Rep. Jim McDermott, at the table across the room. Quite the coincidence. :-)

We came back, I put in CD3, and waited for the server install to finish. In the meantime, I was downloading AVG and reviewing the install steps. All told, about 3 hours and change after we had started, the server was installed and up and running. Next, of course, I had to immediately install SBS SP1. Fortunately I had copied that onto my laptop, so I copied it over to the server and installed the components. In the meantime, I also installed AVG and started to configure the client PCs to use the AVG client and configured the monitoring and reporting functionality as well.

We were making good progress, although it was getting late in the night. Once all of SP1 was installed, I ran through the wizards, adding users and computer accounts. I also made sure to hit Windows Update for the latest security patches (fortunately SP1 is still fairly up to date).

And it was here that I made my next mistake, leading me to Epiphany #4:

Epiphany #4: Never ever rename the client PCs if you can avoid it.

Example of epiphany #4: After running through the Add User and Computer Wizard, I accepted the defaults, not thinking about the name changes for the PCs (I was getting tired). We ran the connectcomputer wizard on each of the PCs, which worked great with practically no problems. Until Jeff, one of the CPAs who was staying late with me to help me out, pointed out that all of their mapped drives, which pointed to each other's PCs, no longer worked because the PC names were all different.

<sigh>

I couldn't really make them change their whole workflow in the middle of the night, so we went to each PC (only about 6 of them) and reset all of their drive mappings. Of course, each PC had something like 6-8 mapped drives, so that was fun and exciting.

So next I just wanted to get their Outlook profiles working. Of course, they had pre-existing mail in old accounts, so I had to go back and import their PST files into their Exchange mailboxes, which didn't take too long (except for one PC, which was strangely slow).

So here I was hopping from PC to PC, resetting mapped drives and importing mail at something like 11PM or midnight. And I came to epiphany #5:

Epiphany #5: Think! Think through the entire process and plan each step carefully before you start.

I thought I had done this, but obviously that was a fallacy. Because it occurred to me that I had been too smart for my own good. If I had really thought through all of the steps I actually needed to go through, I wouldn't have been so optimistic about either a.) the time required or b.) the potential snafus that I would encounter along the way.

Finally we reached the point where the clients were up and running, anti-virus was installed, backup was configured, users could login, the only thing left to do was copy the original server data back onto the SBS server from the backup drive, recreate their shares, and all would be well for the morning. Unfortunately, the owner had carefully backed up all the data that afternoon and then, like every day, took the removable drive home with him. This did lead to another epiphany, but it was superceded the next morning, so I'll save that one for later.

At this point, I had done all the damage I could do. Everything was up and running, even the Win98 machines were configured to the domain as best as they could be, and everything was working (sans data). The owner was going to come in the next morning and copy the data back onto the server himself, so at 1AM I finally headed home, planning on coming back at 9:30 to just make sure the data copy went OK and answer any questions/fix any problems that came up. I figured I'd be out of there by 11:30, 12 at the latest. Oh, the lies we tell ourselves sometimes. But that's for another post...