Yesterday at QUT i dropped my “every day hard drive” in the elevator while swapping with my Team Foundation Server Drive and while the dropped drive would spin up it wouldn't boot any more -sigh.  Mounting it in an external caddy and running chkdsk would produce failures at random intervals with some very unpleasant noises.  After buying another drive I was thinking about the easiest way to get my old configuration back before leaving for CSU in morning Typically takes a couple of days of continuous installs) when I remembered I had made an Ximage image of the drive back when I first started playing with Ximage –Yeah!

 

Unfortunately it wasn’t as easy as doing an Ximage /apply as the image was over 32 gig and you can not format a partition with Format.exe with the Fat32 file system on any volume over 32 gig -and I could not use NTFS due to the “Access Denied Error” on the system volume information directory on NTFS volumes with Ximage….

 

So what I did was get rid of the "System Volume Information" -something you can not do on a mounted drive by mounting the image using

 

Ximage /mountrw c:\old_drive f:\chuck.wim 1

 

Then I was able to navigate to my c:\old_drive directory and rename the system volume information directory and commit the changes with

 

Ximage /unmount c:\old_drive /commit

 

Note this took a very long time – and I tied to kill it as I thought it was hung but in either case this rename was committed and I am now able to apply the image to the new drive. 

 

Remember in order to mount the image as a directory you need to install the Windows Imaging File System Filter