Next week I am at StarEast and thought this would be a good time to start working on my demos I am doing. (Nothing like thinking ahead!<g>)

One of the demos I plan on doing is of Load testing a web site – So I started downloading a sample website using our new Web platform installer and everything is going well for 15 minutes (yes I am on a slow connection) and the installer asks me the SA password for SQLExpress.  hmmm since TFS installed SQL Express for me silently I don’t remember even enabling mixed mode let alone setting the sa password….With no option but cancel all that time invested is rolled back! grrrr

Of course the “easy” option is to install SQL Management Studio and simply right click on my SQL Express instance and set to mixed mode and give sa a password -  but that is a 3 gig download that will take forever where I am at….

So here are the steps required to manually put SQL Express into mixed mode and get it working with Web Platform installer. (these directions are as much for myself next time I get in this situation)

 

1. Enable your sa account:

Open the developer command prompt and type

OSQL –E

1> ALTER LOGIN SA ENABLE

2. Give the sa account a proper password

Using the same OSQL Session as above

1> sp_password @old = null, @new = ‘Pass@word1',  @loginame ='sa'
2> go
1> exit

 

3. Change SQL Express to use mixed mode authentication

Open regedit search for “LoginMode” under MSSQLServer

Change the value to 2

Restart your .\SQLExpress  Microsoft SQL Server service

 

Restart the Web Platform installer and Viola you can now install a sample website

-Chuck

 

 

image