IronPython 2.6.1 comes in two flavors – one that runs on top of .NET 4.0 RC, and one that runs on any other framework starting with .NET 2.0 SP1.  They can be downloaded here:

Note: The .NET Framework 4.0 RC is required for the latter release and can be downloaded at http://www.microsoft.com/downloads/details.aspx?FamilyID=a9ef9a95-58d2-4e51-a4b7-bea3cc6962cb&displaylang=en