Sorry for two link-listings in a row, but you might find this interesting:

http://blogs.msdn.com/windows_installer_team/archive/2005/08/05/448386.aspx

Thank goodness all you have to worry about is:

<FailIf 
   Property="VersionMsi" 
   Compare="ValueLessThan" 
   Value="3.1" 
   String="Invalid Windows Installer Version"/>