Just to save you a search and a few clicks (and to save me time later), here are the versions of Java which support Windows 7:

1.4: >= 1.4.2_23

1.5: >= 1.5.0_21

1.6: >= 1.6.0_14

If you have an application which comes with its own JVM, you should check to see if it’s currently enough to be supported, and if not, you can always try swapping out the JVM for that version.