The Microsoft Dynamics CRM Blog
News and views from the Microsoft Dynamics CRM Team

Microsoft Dynamics CRM and IE8 Tweak

Microsoft Dynamics CRM and IE8 Tweak

  • Comments 16

CRM MVP Julie Yack shares with us a tip she recently discovered.

IE8

I recently installed SP2 for Office 2007 on my Vista Enterprise laptop, which includes IE8 with the install.  Once I installed it I began experiencing a rather annoying behavior in CRM.  I would open through a series of windows (in my particular case I was working with Workflows in the Settings section) and each time a new window needed to open, I would get the error message that a pop-up was blocked and that I needed to make sure that my CRM server was in my safe sites list.  Also, when this message displayed the pop-up had in fact “popped up” but was minimized.   This only happened when using the Outlook client, not the browser and only on my laptop, not my desktop.

IE8sec So I of course assumed that the new IE8 install did not actually take all my settings as it offered and I accepted.  But when I looked at pop-up blocker settings, my CRM server was most certainly there.  So I remove it from the list, close and restart IE8.  No difference.

It was annoying, but not a show-stopper for me so I sat on it a day.  During that time we had reason to re-start the CRM server (independent of any of my current annoyance).  Still no difference.

Frustrated, I emailed a group of very smart people, my fellow CRM MVPs, to see if anyone had heard of this and had solved it.  Got back a couple of questions and comments, but mostly just the sound of crickets.

Then my friend Menno te Koppele (my favorite “CRM freak”) sent me a series of instant messages and saved the day.  Here are the steps:

In IE8 go to Tools->Internet Options->Security tab.  Once there, click to “Reset all zones to default level”.  Additionally, click “Enable Protected Mode”.  I had already had protected mode selected, so I unchecked it, applied it, closed and restarted both IE and Outlook.  Then went back to re-check it and apply it.  Again, close and restart both IE and Outlook.  This took care of my problem!

Cheers,

Julie Yack

Technorati Tags: ,,
  • PingBack from http://microsoft-sharepoint.simplynetdev.com/microsoft-dynamics-crm-and-ie8-tweak/

  • Can you put me in contact with your friends :)? It does not work for me. It only works with Protected mode disabled.

  • Great Information to have.  I am sure this will come up for users.

    Thank you for sharing!

  • The bit that is missing here is that the 'Protected mode' is per zone.  So my problem was that my CRM server was in the 'Trusted' zone - to fix I clicked on the 'Trusted' zone - clicked the 'Protected mode' - saved - and it worked.

  • Gary, you are right. Asserting your comment, after fumbling around I also found that you must enable the Protected Mode for the specifi zone where your CRM server opens. Windows 7, IE 8 and CRM ROllup 4 are rocking again now.

  • Parece que ya se está convirtiendo en una costumbre el que cada pocas semanas anunciemos una nueva actualización

  • Greate information to have: it worked for me (after reading the comments in addtion to the first tip)

  • Thank you for the tips! After putting it all together, CRM appears to working perfectly. I just shut down Outlook while I was changing the IE8 settings and didn't reopen until I was done, to save a step. I'm glad not to have to spend time on a call to Support!!

  • None of these fixes work for my customer. He has IE8, Outlook 2007, we're using CRM IFD in the Intranet Zone, with protected mode on Internet, restricted sites, and when protected mode is on in Intranet zone, you are prompted for creds. If you turn it off, no prompt for creds but you get the popup window all day long, and into the night...

  • I am having the same issue as Michael. If I enable the protected mode for Trusted Sites, I continuously get prompted for credentials. I read another thread that mentioned disabling UAC in Vista, but that didn't work either. I have also installed update rollup 5, which did not help matters.

  • I am having the same issue as Michael. If I enable the protected mode for Trusted Sites, I continuously get prompted for credentials. I read another thread that mentioned disabling UAC in Vista, but that didn't work either. I have also installed update rollup 5, which did not help matters.

  • When I checked "Enable Protected Mode" the pop-up message is disapeared. But the result of this check is that all CRM reports gives an error when printing. Any ideas?

  • Make sure that you check that internet options: Automatic logon only in intranet zone "is" checked. Also in the advanced tab that "enable integrated windows authentication" "is" checked. If you are using windows 7, also ensure that your stored credentials are not interfering with your "automatic" login.  

  • the problem is also:

    the popup issue disappears when using protected mode - fine so far. But in this configuration when you open a regular email item in outlook an use the crm toolbar item "show in CRM" than you get an empty IE Windows, which show this kind of URL: http://crm.domain.com:5555/TESTCOMPANY/_root/stage.aspx.

    this sucks!

  • This is what I found out:

    details:

    Dynamics CRM 4.0 (hosted) through Outlook with the connector.

    Windows Vista Home premium

    IE 8

    I have tried the above. Did not work. If I enable protected mode in my trusted sites/zones, I lose the "pop-up warning"... but... I have to give in my credentials every time. This is even more @%^@$%@$%...

    I also got rid of Google toolbar, Yahoo toolbar and MS Live toolbar and any other pop-up blocker program etc.

    The funny thing is that if you open Explorer and keep it open, you just have to give in your credentials only once! So you can work all day without those ignorend pop up or giving in your credentials every time.

    Ofcourse this is just a lousy solution. I want it to work the way it should be.

    How is it possible that MS has not yet solved this problem or at least give good directions. I now have been working on this for 3 hours!

    Anyone found a better way?

Page 1 of 2 (16 items) 12
Leave a Comment
  • Please add 3 and 5 and type the answer here:
  • Post