Ok, wanted to install Xine, based on the recommendation of one of the posters.  I opened synaptic and got a message saying dpkg had been interrupted and i needed to run: "dpkg --configure -a"

Ok, slightly offputting.  If i'm a a regular user i'm going to have no idea what the heck i'm supposed to do about that.

Luckily this gave me a chance to find and run the terminal app.  However, why i tried to run the command in that terminal i then got the message:

foo@metasyntactic:~/Desktop$ dpkg --configure -a
dpkg: requested operation requires superuser privilege

Yikes!  WTF??  This requires superuser privilege??  Why?  It's my computer, how am i not a superuser on it?  Synaptic has no problem installing apps on my machine without bothering me with issues of "superuser"ness, so why is this dpkg app getting in my way.  Luckily i've had some experience with unix systems before, so i knew about the "sudo" command.  After running that above command with sudo things were in a good shape.  But this is seriously something that i would be doing a fair bit of troubleshooting for if a non-techie person ran into this.  That does not make me happy at all.  I've been spoiled by OSX, and i was hoping things would be better wrt this sort of thing on Ubuntu.