Sigh... I get a lot of ambiguous and undetailed questions... and then users wonder why my responses are not forthcoming. The following is an example...

Question:

David,

I noticed your recent posting in a newsgroup about a problem you had getting a virtual directory to a remote share working in IIS. I'm having the same problem; IIS can 'see' the files, but I get a 500 error when I try to browse. I tried following the how to link posted in the newsgroup, but the page could be found. Could you tell me the steps you took to fix the problem? Thanks,

Answer:

Unfortunately, I post a lot of responses to a lot of newsgroups on a lot of topics which frequently include the keywords virtual directory, remote shares, and IIS... and since I am not clairvoyant nor psychic, I really have no idea what topic, post, URL link, nor steps you are referencing. Helpful contextual information include a URL link to the newsgroup post or the complete Title of the newsgroup post (so that I can search for it), the link that supposedly cannot be found, and your actual problem. And without diagnosis, I do not recommend that you assume that you have the same problem as anyone else. Many things *look* similar and produce the same HTTP response, but they are definitely not the same thing...

In general, I recommend reading the following URL when dealing with Remote UNC shares and IIS. It covers architecture, authentication methods that work (and why and how), configuration of IIS and the remote File Server, Performance Tuning tips, and common troubleshooting tips. It was written by the IIS team member primarily responsible for making those scenarios work, so I take it as gospel.

http://www.microsoft.com/technet/prodtechnol/windowsserver2003/technologies/webapp/iis/remstorg.mspx

Regarding your problem: I suspect you are talking about IIS Manager UI being able to 'see' the files, but IIS Web Server is not able to serve it when Browsed via HTTP. I am not certain why those two actions have any relation to each other. IIS Manager UI runs as a locally-authenticated administrator to browse the UNC Folder; IIS Web Server uses some remotely impersonated user account (may not be the administrator) to browse the UNC Folder. The two user identities are not necessarily the same nor do they have the same login, so results may differ.

Put another way, the IIS Manager does NOT provide a preview of configured website behavior when you browse. It provides useful information for website configuration. For example, you may ACL resources to require authentication and accessible only to certain users, but when you view it with IIS Manager UI, you certainly do not get authenticated nor do you need to be certain user to see it. So, everything looks good in IIS Manager, but you suddenly get 401s when you try to browse with the wrong user account. This is no different than the 500 error mentioned earlier, so I do not see UI behavior correlating with website behavior...

//David