Developing for Dynamics GP

by David Musgrave (Perth, WA, Australia) and the Microsoft Dynamics GP Developer Support Team (Fargo, ND, USA)

Side-by-side configuration is incorrect error message given launching Dynamics GP

Side-by-side configuration is incorrect error message given launching Dynamics GP

Rate This
  • Comments 19

Patrick Roth - Click for blog homepageIt is somewhat coincidental that one of the system techs had a case Friday running into an error launching Dynamics GP 2010 and the release of Microsoft Dynamics GP 10.0 Service Pack 5.  What do these events have to do with each other?  Read on...

This customer had just installed GP 2010 and it worked correctly on all machines but one.  On the one machine, Dynamics GP 2010 refused to launch and instead gave the error:

F:\Program Files (x86)\Microsoft Dynamics\GP2010\Dynamics.exe

The application has failed to start because its side-by-side configuration is incorrect. Please
see the application event log or use the command-line sxstrace.exe tool for more detail.

As suggested by the message, looking in the Application Event Log shows the message:

Activation context generation failed for "F:\Program Files (x86)\Microsoft Dynamics\GP2010\Dynamics.exe". Dependent Assembly Microsoft.VC90.MFC,processorArchitecture="x86", publicKeyToken="1fc8b3b9a1e18e3b", type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.

I've run across this issue on my own systems so I had a pretty good idea of where to look.

What I'm surprised is why this should happen.  As Dynamics GP 2010 is installed; the Visual 2008 C++ Runtime Redistributable should have also been installed as well.  Of course I don't know how GP 2010 was installed - maybe it wasn't "installed" and just copied?

But in any event, the solution is to load or reload the components again.

On my Windows 7 64 bit machine, if I look in the add/remove programs window I see:

I have a bit newer version of the runtime as well as the ATL Security Update version (though you can't tell from the name what version is what).

I suggested the customer download and install the 32 bit Microsoft Visual C++ 2008 Redistributable from Microsoft Downloads.  And for the heck of it and to get the 32 bit Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package ATL Security Update and install that as well.  It can't hurt and I suspect that it will be required when the Dynamics GP 2010 SP1 ships sometime this fall.

After loading these suggested redistributables, the user could now launch Dynamics GP 2010 successfully.

If we had wanted to dig into this a bit more, we could have done what the initial error message suggested and used the sxstrace.exe utility to trace an application trying to load these components.  This post on the Code Project site talks about the side-by-side configuration error message, the technical reasons you'd get this, and a quick review of the sxstrace.exe application.

So what does this have to do with Dynamics GP 10.0 SP5 or am I just trying to get as many links to previous posts as possible by referencing the SP5 release post?

With 10.0 SP5 (10.0.331 runtime), the reason for the bold warning messages on the Dynamics GP 10.0 service pack page is that you need the latest Visual C++ 2005 ATL security update to work.  If this wasn't installed (and we didn't install it for you as the SP5 install checks for) then you would get this same error that the customer above did on GP 2010 - just for a different version of the components since Dynamics GP 10.0 is built on Visual Studio 2005 and not VS 2008 like GP 2010 is.

Best Regards,

Patrick Roth
Developer Support

  • Post from Mark Polino at DynamicAccounting.net

    msdynamicsgp.blogspot.com/.../side-by-side-configuration-is-incorrect.html

  • I try to down load certain e-mail from one paticilar person an I get this message: c;\terryconnell\appdata\local\microsoft\windows\temporary internet. side-by-side configuration is incorrect. please see the application event log for more detail.

  • Hi Terry

    Not sure if your issue is related, but you can try the suggested fix anyway.

    David

  • Hey I'm not sure if it's the same thing but like everything i've downloaded/tried to play it will say side by side error usually the program files (x86) i'm not sure how i should do this it even does it when i try to open skype it says exactly      ''C:\Program Files (x86)\Skype\Phone\Skype.exe'' The application has failed to start because it's side-by-side configuration is incorrect.  Please see the application event log or use the command-line sxstrace.exe tool for more detail.

    What should i do?

  • Hi Daniel

    You could try installing the Visual C++ files as described in this post.  Otherwise, check with Skype support  or on their forums.

    David

  • I am trying to fix this problem on my computer. However when I try to reinstall the components i get the same side by side configuration issue. any suggestions?

  • Tim,

    I assume you mean "after i install the compents" and not _when_ you install the components.

    You don't mention what version of GP you are using - it would tell us whether you need the VC 2008 version for GP 2010 as I did above or if you need the VC 2005 version for GP 10.  

    Assuming that the updates show in your add/remove programs (thus truly installed), then the only resolution to you (and Daniel) would be to run the sxstrace.exe to seewhat the Dynamics.exe or other component is "looking" for.  Then verify that you have it installed or find the installation package that will install that component.

  • I get this for Cyberlink PowerDirector:

    C;\ProgramFiles\Cyberlink\Powerdirector\PDR9.ex

    The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail.

    I'm on a 32-bit Windows Vista.

  • While I by no means speak for Cyberlink or can tell you how their app was built, I would think the solution is going to be the same.

    If you check your application event log in windows, there will be an entry for this application.  It will look similar to my screenshot for the error Dynamics GP was getting.

    In it it will tell you the assembly and the version that this application is looking for.  Now depending on what the file is, you'd then have to load that version of the components on your system.

    Since I don't have your app and repro the issue, I can't tell you the version you need.

    patrick

  • got that error message when opening an mp3 audio file after uninstalling iTunes (which gives me an Error 7 message that suggest me to uninstall)

  • Hello Patrick,

    I also have same problem. My project is of vb.net. I installed my project in one of my japanese machine. When i try to run my project .exe file. Its giving me error message saying:

    "Side-by-side configuration of the application for this is not correct, could not start the application. For more information, please see the application event log"

    I thinks this issue is similar to yours. Can you please guide, is this same or any else?

  • Rahul,

    You might have build your app as a debug executable and so requires the debug components which a typical machine won't have.  Try building "retail" and see if that resolves the issue.  I didn't mention this in my article because no end users would ever have the debug version of this exe.

    If retail also fails, then it is going to be the same solution as this article though perhaps not the same version of whatever assembly it is failing on.  You'd have to check the event log to see which specific version of the file is failing and then verify that this version of the dll is loaded on the target machine.

    I guess it could be language specific as ou mention a "japanese machine" is giving you the issue but that might just be coincidental.

  • Dear Patrick

    Thank you for your solution for the configuration problem. Now my problem solve and really thank a lot to you

    Have a nice day!

  • Andrew,

    You are so very welcome - glad it could help.

  • I get this error with all programs that i try to open or download been working on it for 2 wks now and don't know what else to do plz help

Page 1 of 2 (19 items) 12
Comments Information

PLEASE READ BEFORE POSTING

Please only post comments relating to the topic of this page.

If you wish to ask a technical question, please use the links in the links section (scroll down, on right hand side) to ask on the Newsgroups or Forums. If you ask on the Newsgroups or Forums, others in the community can respond and the answers are available for everyone in the future.

Leave a Comment
  • Please add 1 and 4 and type the answer here:
  • Post