Lol, well I couldn’t resist it, I scored a Via EPIA CN13000 Embedded Motherboard at the Oz MEDC, the boards are mini ITX form factor and run on the smell of an oily rag.

The motherboard draws 16 to 17 watts, a 2.5in drive draw 3 to 4 watts so all up the system draws approx 20 watts, it runs cool and near whisper quiet.  If you ever wondered what happened to Cyrix x86 Technology then it found its way on to these boards. 

So armed with a A$100 1Gig memory stick, a spare 2.5in drive and a nice small case I had all the pieces for the project.  (I just loaded up from an external USB2 CD Drive)

Yes possibly a bit risqué for MSDN and with no expense spared here’s an “x rated” cheeky peek at the internals of possibly the world's smallest TFS system:)

Thought it would be fun/useful/portable to run the board as a Workgroup Team Foundation Server, so I loaded Windows Server 2003 SP1, SQL 2005, Sharepoint, some hotfixes and Team Foundation Server . 

I have to say that I’m delighted with the system performance and stability, it’s been running now for a couple of weeks without any issues.  Yup most of the time it’s not doing a lot (and I didn’t install the build server), but when it does, it does it quickly and I’m developing one of those dependency disorder thingmes for TFS Source ControlJ

Lol, and yeah I couldn’t resist loading up the June CTP of .NET Framework V3 and the system was processing 3000 - 4000 WCF messages per second over TCP.  It also makes for a nice FTP and IIS Server, not bad for a system that draws around 20 watts when active.

Couple of things I picked along the way

1)      Wanted to reference the source control, reports, work items etc via an external URL so I could access from home, work, hotels, conferences etc – so I needed to register the address in TFS – check out http://ognjenbajic.com/blog/doc/vsts/enabling%20team%20foundation%20system%20ssl.htm#_Toc126043467, actually I’ve not set up SSL yet, so the Sharepoint admin still runs on port 17012 but you’ll see the XML doc  you’ll need to configure and the command to run (don’t forget to reboot after)

2)      Did hit an authentication problem and  spotted the resolution on Rob Caron’s blog at http://blogs.msdn.com/robcaron/archive/2005/10/07/478336.aspx

3)      I didn’t set up alerts and I did get a pesty error message in the logs saying invalid “From” address – spotted the fix at http://blogs.vertigosoftware.com/teamsystem/archive/2006/07/11/Changing_SMTP_settings_on_Team_Foundation_Server.aspx

Anyway,  just shows what you can run on such a small system and TFS rocks!!

So go on, Fill Ya Boots Man and give it a whirl:) 

Cheers, Dave

Ps, click on the "Fill Ya Boots Man" link, Becky and the Demolition Man is one of the funniest things on the web at the moment.  Thanks Mike!!