Microsoft releases cumulative update (CU) packages for AppFabric 1.1 for Windows Server. Each cumulative update package contains all of the fixes that were released in previous update packages for both cache server and cache client. At the time of this writing there are 5 cumulative update packages that have been released:

Cumulative update package 1 for Microsoft AppFabric 1.1 for Windows Server
Cumulative update package 2 for Microsoft AppFabric 1.1 for Windows Server
Cumulative update package 3 for Microsoft AppFabric 1.1 for Windows Server     
Cumulative update package 4 for Microsoft AppFabric 1.1 for Windows Server
Cumulative update package 5 for Microsoft AppFabric 1.1 for Windows Server

These are the AppFabric 1.1 cache dll versions Microsoft has released:

RTM: 1.0.4632 (29-Nov-2011)
CU1: 1.0.4639 (20-Feb-2012)
CU2: 1.0.4644 (29-May-12)
CU3: 1.0.4652.2 (27-Nov-2012)       
CU4: 1.0.4653.2 (28-Mar-2013)
CU5: 1.0.4655.2 (03-Mar-2014)

CU3 and later versions including CU5 require .NET Framework 4.5 on cache servers as documented on the KBs. However .NET 4.5 is not a prerequisite on cache clients to use client binaries in CU3 or CU4 or CU5.

You can search for AppFabric cumulative update packages at http://support.microsoft.com for the phrase (including the quotes): 

"cumulative update package" appfabric

The following query does this search for you. Choose the latest one:

http://search.microsoft.com/en-us/supportresults.aspx?form=mssupport&q=%22cumulative%20update%20package%22%20appfabric