Today’s post comes from Brett Keown. As they worked on a supported issue together, Brett and a recent customer also had the opportunity to speak about the CodePlex “TFS to TFS Migration Tool”. The TFS to TFS Migration Tool is not supported by Microsoft CSS, and Brett did not help the customer with it’s usage, but it was an interesting opportunity for him to learn about a real-world scenario with the the tool and see some issues encountered… which he reports for us here today. Hopefully you will find this useful if you ever encounter a similar situation and problem.

-Trev

 

WARNING: The TFS to TFS Migration tool discussed here is not supported by Microsoft CSS. For support with the TFS to TFS Migration tool please visit the CodePlex TFS to TFS Migration discussion site. This is the official discussion and support forum for the tool. Thanks to Bill, Curtis, Ed, Graham, Matthew, Jim (and all those behind the scenes) for the great tool and guide to its use. Images in this post were taken from the End User Guide.

A recent customer of mine was experiencing some TFS issues, and was also working to migrate some source code and work items between two TF servers. While we here at Microsoft do not support this tool, and I could not help them with it in our support case, the customer and I got to talking about this migration. The customer was attempting to perform a one-way migration of a single project between two Team Foundation 2008 Single Tier Servers. The customer had gone through the entire setup process, created the project on the new server (all of 15 minutes!) and then migrated their source code. This went flawlessly. Their next step was to migrate work items…

On the first attempt they received an error message over and over in the migration progress window saying “Synchronization engine has crashed”. After checking the forums they found that the most common cause for this is the account being used for migration not being a member of the target server’s TFS “Service Accounts” group. Curtis Pettit has documented a fix for that here: http://blogs.msdn.com/curtisp/archive/2008/12/05/administrator-permissions-are-not-enough-for-wit-migration.aspx". He says, from the Application Tier, open a command prompt in the installation directory for TFS, and then run this command


TFSSecurity.exe /g+ "Service Accounts" "domain\userName" /server:http://serverName:8080


As I said previously, that was the most common reason and fix for this error message. Unfortunately for my customer, that was not the case in their migration. Upon further review and testing they found that they were attempting to link work items to a version control migration session that did not exist (they had deleted it when the SCC migration had completed). On their “Add/Edit Migration Session” dialog they had selected the option to “Enable Linking”, but the “Linked Version Control Session” selected did not exist!

image

Once this was resolved, work item migration completed.

- Brett