David's Cloud Strategy Blog

Everything SaaS, Azure and Cloud

"Feed Headlines" Vista gadget broken

"Feed Headlines" Vista gadget broken

  • Comments 16

I love the built-in RSS gadget in Windows Vista. If you've never used it before, this is how it looks:

"Feed Headlines" gadget

... but life is hard, so it broke at one point and I was started wondering on the 5th day that I still see the same news headlines for days now, no news in the IT world ... I was started thinking about selling my stocks :)  Then, I found that it's simply not refreshing the feeds.

I was checking the feeds in Internet Explorer (Ctrl + Shift + J -> J, like RSS :) and found that the feeds here were way expired too! Then, started asking around in internal distribution lists. Immediately got an answer from Walter VonKoch, who sent a me a checklist. It turns out that the feeds are updated by a task configured in Windows Task Scheduler. Deleting and recreating the task solved the problem.

See the checklist on Walter's blog: http://blogs.msdn.com/rssteam/archive/2007/01/08/feeds-not-updating.aspx

Leave a Comment
  • Please add 3 and 2 and type the answer here:
  • Post
  • I'm glad to see that I'm not the only one with this problem but can you please "dumb down" the instructions?  For instance, where do I type sc queryex schedule?  Do I open a command line?

    Thanks!

    JohnD

  • Hi John,

    Sorry for not answering so far. Yes, please open a command window (Start -> Run, then type CMD and hit Enter), then type the commands there one by one and hit Enter after each line. Please inspect the output of each line and check the next steps at Walter's weblog. Please let me know if you have any questions! Cheers!

    David

  • David,

    Thanks for getting back to me.  I tried the instructions and saw nothing immediate.  Just for fun I tried stopping and restarting the service but there was no change.

    I then scrolled down through the responses below the instructions and saw a suggestion to select "close unused folders in History and Favorites" from the ADVANCED tab in Internet Options. Then I noticed my feeds updated.

    So I'm not sure what action worked.  Either my playing around or checking that advanced option.  The latest feeds are showing up.  We'll see what tomorrow brings....

    Thanks!

  • Hey John, it sounds funny, I'm glad that it got solved. Hope it works well now.

    David

  • Min just stuck, sep 1. checklist did nothing, nothing was wrong per the checklist.

    This stuff , RSS feeds, has worked forever in firefox. I dont get why this stuff is breaking and not being updated.

    Rather sad.

  • Mick, is there anything that we can help you in? Cheers, David.

  • hey guys, I had the same problem twice (for two different computers I had bought with Windows Vista) the bad thing is  in an attempt to fix it, I uninstalled the gadget. is there anyway I could get it back so I can fix it? I just gotta say I love the Feed Headlines gadget

  • Hey Michael, check out Walter's checklist - this is how I've fixed mine: http://blogs.msdn.com/rssteam/archive/2007/01/08/feeds-not-updating.aspx. Good luck!

    David

  • Thanks David. I had gone through the checklist before, but still didnt' get it, so I did all the rest of things. I use Opera for my primary web browser and it hadn't given me a problem, but I opened up IE and subscribed to the feeds there after clearing all the cache and temporary internet files and such. It still didnt' work, but I just did a system restore to the last point in time when it was working and voila! Different way of solving, but at least it worked. Thanks a lot!

  • Thanks David. I had gone through the checklist before, but still didnt' get it, so I did all the rest of things. I use Opera for my primary web browser and it hadn't given me a problem, but I opened up IE and subscribed to the feeds there after clearing all the cache and temporary internet files and such. It still didn't work, but then I just did a system restore to the last point in time when it was working and voila! Different way of solving, but at least it worked. Thanks a lot!

  • Thanks David. I had gone through the checklist before, but still didnt' get it, so I did all the rest of things. I use Opera for my primary web browser and it hadn't given me a problem, but I opened up IE and subscribed to the feeds there after clearing all the cache and temporary internet files and such. It still didn't work, but then I just did a system restore to the last point in time when it was working and voila! Different way of solving, but at least it worked. Thanks a lot!

  • I don't get this. technology gives me headaches, I can't wrap my brain around it.

    what's the simple answer to fixing this problem? other than just removing it from the gadget bar and going back to looking up news headlines online?

  • I followed David's url, but I haven't updated Vista-MS may have, but not with a whole new program, if that's what they're saying. then I opened up one of the feeds and clicked on F5, but it appears that all I got from that was a pop-up window with links in it. it's not fixing the problem so I guess that's not the issue. it was worth a try, though. didn't understand the rest of the instructions, not worth that kind of struggle-no glitch is. why no-one thinks of simple fixes for these problems, I have no idea. we don't all speak or think g(r)eek, you guys need to put it out there in very simple form. it disgusts me that you never do. it's always advanced programing instead of a 3 step process. what don't you get that not everyone's tech savvy? not doing it, folks. I don't understand it and after 12 years online I think I can say I never will. it's gibberish to me and to a heck of a lot of other people.

  • My Vista Ultimate 64 bit version desktop, laptop and a Vista Home Premium Laptop's News Feed Gadget that is included with the operating system are not working.  My desktop and laptop gadget was working until the feed simply stopped updating after June 29th 2009.

    The new laptop never worked from day one.  The only common denominators seem to be that I updated to IE 8 and also SP2.

    I've tried every solution on this page to no avail.

    Maybe someone can help me figure this out?  I've tried uninstalling IE 8 and reverting to IE 7 but that did not work either.

    To be specific I am referring to the MSNBC feed that comes as a default gadget with the Vista O/S.

  • I have Vista for my laptop and I was having the problem with my Feed Headlines not working, I followed the CMD instructions and found out that my Task Scheduler image had been corrupted I fixed that using the commands and then in internet explorer i went to tools, delete browsing history, delete all and then the Feed Headlines gadget updated

Page 1 of 2 (16 items) 12