Dan's Blog

I am Principal Program Manager at Microsoft leading the Business Platform Division's (BPD) community team. BPD includes SQL Server, SQL Azure, BizTalk, AppFabric, and other technologies and services.

Up & Running on Win7

Up & Running on Win7

  • Comments 1

Rock and Roll! Yesterday I did a clean install of Win7 x64 Beta on my Lenovo x301. Setup was fast and completed without any issues. In fact it had no problem with the SATA drive set in AHCI mode. The Vista RTM install couldn’t handle that. I had to use a custom driver or switch it in to compatibility mode.

Boot time is lightening fast as is resume from sleep. I haven’t played much with hibernate yet. Yes this is a clean OS install but I did a clean install of Vista on the same machine recently and it was not nearly as fast.

Over all performance feels much zippier. Apps load more quickly and the system feels far more responsive.

So far I’ve only run into three minor issues:

1) The current release of Live Mesh doesn’t play nicely with Vista video settings. I got a dog food QFE from the Mesh team that cleared the issue up. I don’t know when this will be released publically. (note: Dog Food is an internal term used for testing another groups product prior to public release.)

2) For some reason Win 7 didn’t play nicely with the sound system. I cleared this up by repairing the driver install. The build of Win 7 I installed is an Microsoft IT (MSIT) build. They mock with a bunch of stuff so I don’t know if I can blame this on Win 7 or not.

3) The start menu froze on me just once. It happened in a strange situation. Again this could have been caused by some Microsoft IT (MSIT) stuff.

So for all of my road testing in the last day I can safely say I’m impressed. I haven’t played with many of the new features yet. Once I do I’ll report back.

Now for the early litmus test – do I want to go back to Vista? So far the answer is no.

Leave a Comment
  • Please add 1 and 5 and type the answer here:
  • Post