Si has tenido problemas con la instalacion de service packs de la version 9 de GP, hay un detalle adicional que probablemente no hayas realizado.

La instalacion del service pack de GP version 9 se anticipa a que tendrias instalado .NET Framework 1.1 SP1.
Lo que no esta contemplado es que en Windows 7 ya no incluye el .NET Framework 1.1 SP1, por el contrario
Windows 7 viene con la version de .NET framework 3.5 SP1

Es por esa razon que cuando intentas instalar los service pack para GP 9, es muy probable que te enfrentes con

el siguiente error:

Error Grave
Se encontro un error grave: La instalacion de Dynamics GP termino prematuramente Presione Finalizar para salir de la instalacion.

 

Afortunadamente no todo esta perdido y no tendremos que pasar horas interminables tratando de descifrar un visor de sucesos o algunos logs.

Los pasos a realizar son los siguientes:

1.- Entra a www.bing.com
2.- Teclea lo siguiente: ".net framework 1.1 sp1" en caso de que la liga no funcione
http://www.microsoft.com/downloads/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&DisplayLang=en

3.- Instala el service pack 1 de .Net framework 1.1

y reanuda la instalacion de tu service pack en tu nuevo Windows 7

Si por alguna razon recibes un mensaje como el siguiente:
"No se puede instalar Microsoft .NET Framework 1.1 Service pack 1 (KB867460)"?

Tenemos a la mano el siguiente KB de Microsoft
http://support.microsoft.com/kb/889109

Hasta la proxima!!!